about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorLily Ballard <lily@sb.org>2020-05-20 16:17:59 -0700
committerLily Ballard <lily@sb.org>2020-05-20 16:17:59 -0700
commit291524258399466a93c82ed6b726933ecb6bb9d1 (patch)
tree23b7fd6441525022c441ce93fed01438f626b32d /pkgs/tools
parent4a302d1b9aab8c767bdae26a1d5bcc5dbdcb796a (diff)
downloadnixlib-291524258399466a93c82ed6b726933ecb6bb9d1.tar
nixlib-291524258399466a93c82ed6b726933ecb6bb9d1.tar.gz
nixlib-291524258399466a93c82ed6b726933ecb6bb9d1.tar.bz2
nixlib-291524258399466a93c82ed6b726933ecb6bb9d1.tar.lz
nixlib-291524258399466a93c82ed6b726933ecb6bb9d1.tar.xz
nixlib-291524258399466a93c82ed6b726933ecb6bb9d1.tar.zst
nixlib-291524258399466a93c82ed6b726933ecb6bb9d1.zip
ffsend: don't require openssl on darwin
The current version of ffsend no longer requires `openssl` on macOS.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/ffsend/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/tools/misc/ffsend/default.nix b/pkgs/tools/misc/ffsend/default.nix
index de67de4fa798..264afc68b67f 100644
--- a/pkgs/tools/misc/ffsend/default.nix
+++ b/pkgs/tools/misc/ffsend/default.nix
@@ -28,9 +28,9 @@ buildRustPackage rec {
   cargoSha256 = "0svmbay9waaq9fpc8lg1nys6l35xsjvkri5v1frlgxida5dzghpq";
 
   nativeBuildInputs = [ cmake pkgconfig installShellFiles ];
-  buildInputs = [ openssl ]
-  ++ stdenv.lib.optionals stdenv.isDarwin (with darwin.apple_sdk.frameworks; [ CoreFoundation CoreServices Security AppKit ])
-  ;
+  buildInputs =
+    if stdenv.isDarwin then (with darwin.apple_sdk.frameworks; [ CoreFoundation CoreServices Security AppKit ])
+    else [ openssl ];
 
   preBuild = stdenv.lib.optionalString (x11Support && usesX11) (
     if preferXsel && xsel != null then ''