about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@gmail.com>2021-02-12 19:43:48 +0100
committerSandro Jäckel <sandro.jaeckel@gmail.com>2021-02-13 00:25:22 +0100
commit231ad4ac169c315691de59715b0e51db35fa768a (patch)
tree7529b822260006d51cc31e312780385f81dd4a5d /pkgs/tools
parent73ac41146bd325ca0b0e32fc203486e3764215ba (diff)
downloadnixlib-231ad4ac169c315691de59715b0e51db35fa768a.tar
nixlib-231ad4ac169c315691de59715b0e51db35fa768a.tar.gz
nixlib-231ad4ac169c315691de59715b0e51db35fa768a.tar.bz2
nixlib-231ad4ac169c315691de59715b0e51db35fa768a.tar.lz
nixlib-231ad4ac169c315691de59715b0e51db35fa768a.tar.xz
nixlib-231ad4ac169c315691de59715b0e51db35fa768a.tar.zst
nixlib-231ad4ac169c315691de59715b0e51db35fa768a.zip
thefuck: Fix tests, add SuperSandro2000 as maintainer
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/thefuck/default.nix16
1 files changed, 3 insertions, 13 deletions
diff --git a/pkgs/tools/misc/thefuck/default.nix b/pkgs/tools/misc/thefuck/default.nix
index d26c750a0c76..ff6a22cef8eb 100644
--- a/pkgs/tools/misc/thefuck/default.nix
+++ b/pkgs/tools/misc/thefuck/default.nix
@@ -1,6 +1,6 @@
 { lib, fetchFromGitHub, buildPythonApplication
 , colorama, decorator, psutil, pyte, six
-, pytest, pytest-mock
+, go, mock, pytestCheckHook, pytest-mock
 }:
 
 buildPythonApplication rec {
@@ -16,22 +16,12 @@ buildPythonApplication rec {
 
   propagatedBuildInputs = [ colorama decorator psutil pyte six ];
 
-  checkInputs = [ pytest pytest-mock ];
-
-  checkPhase = ''
-    export HOME=$TMPDIR
-    export LANG=en_US.UTF-8
-    export XDG_CACHE_HOME=$TMPDIR/cache
-    export XDG_CONFIG_HOME=$TMPDIR/config
-    py.test
-  '';
-
-  doCheck = false; # The above is only enough for tests to pass outside the sandbox.
+  checkInputs = [ go mock pytestCheckHook pytest-mock ];
 
   meta = with lib; {
     homepage = "https://github.com/nvbn/thefuck";
     description = "Magnificent app which corrects your previous console command";
     license = licenses.mit;
-    maintainers = with maintainers; [ ma27 ];
+    maintainers = with maintainers; [ ma27 SuperSandro2000 ];
   };
 }