about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAllan Espinosa <allan.espinosa@outlook.com>2015-09-23 13:25:53 +0900
committerAllan Espinosa <allan.espinosa@outlook.com>2015-09-23 13:26:37 +0900
commit22e57d6f2620e652e4cc181993179ea24956995c (patch)
treed2e0aee8d22d73fdd15cb4dcb39830a31949b60a /pkgs/tools
parentdf665ded7e9a5980c6ae51a9df8203706c1150c9 (diff)
downloadnixlib-22e57d6f2620e652e4cc181993179ea24956995c.tar
nixlib-22e57d6f2620e652e4cc181993179ea24956995c.tar.gz
nixlib-22e57d6f2620e652e4cc181993179ea24956995c.tar.bz2
nixlib-22e57d6f2620e652e4cc181993179ea24956995c.tar.lz
nixlib-22e57d6f2620e652e4cc181993179ea24956995c.tar.xz
nixlib-22e57d6f2620e652e4cc181993179ea24956995c.tar.zst
nixlib-22e57d6f2620e652e4cc181993179ea24956995c.zip
oathToolkit: Support darwin
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/oath-toolkit/default.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/pkgs/tools/security/oath-toolkit/default.nix b/pkgs/tools/security/oath-toolkit/default.nix
index 8f96a5067d12..216ce3d23364 100644
--- a/pkgs/tools/security/oath-toolkit/default.nix
+++ b/pkgs/tools/security/oath-toolkit/default.nix
@@ -1,5 +1,10 @@
-{ stdenv, fetchurl, pam }:
+{ stdenv, fetchurl, pam, xmlsec }:
 
+let
+  securityDependency =
+    if stdenv.isDarwin then xmlsec
+    else pam;
+in
 stdenv.mkDerivation rec {
   name = "oath-toolkit-2.4.1";
 
@@ -8,11 +13,12 @@ stdenv.mkDerivation rec {
     sha256 = "094vbq66sn5f2dsy14hajpsfdnaivjxf70xzs91nrsq0q75l5ylv";
   };
 
-  buildInputs = [ pam ];
+  
+  buildInputs = [ securityDependency ];
 
   meta = {
     homepage = http://www.nongnu.org/oath-toolkit/;
     description = "Components for building one-time password authentication systems";
-    platforms = stdenv.lib.platforms.linux;
+    platforms = with stdenv.lib.platforms; linux ++ darwin;
   };
 }