about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2018-11-30 18:16:13 -0500
committerGitHub <noreply@github.com>2018-11-30 18:16:13 -0500
commit22926c8b84f2f97d7c37fea74016a00bb562565e (patch)
tree9e21b9aba4db2705bca9e21961e5ea5d98020dc5 /pkgs/tools
parent7131b7f2603f9fa3203a7ae1ba7506425e1a7690 (diff)
parent4ed2dd919b316a75d2b2c5bbfa5b45e332384945 (diff)
downloadnixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.tar
nixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.tar.gz
nixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.tar.bz2
nixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.tar.lz
nixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.tar.xz
nixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.tar.zst
nixlib-22926c8b84f2f97d7c37fea74016a00bb562565e.zip
Merge pull request #51284 from kampka/upgrade-gandi-cli
gandi-cli: 0.19 -> 1.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/gandi-cli/default.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/pkgs/tools/networking/gandi-cli/default.nix b/pkgs/tools/networking/gandi-cli/default.nix
index be488e788b41..99db0ab25075 100644
--- a/pkgs/tools/networking/gandi-cli/default.nix
+++ b/pkgs/tools/networking/gandi-cli/default.nix
@@ -1,17 +1,16 @@
-{ stdenv, pythonPackages, fetchFromGitHub }:
+{ stdenv, python3Packages, fetchFromGitHub }:
 
-with pythonPackages;
+with python3Packages;
 
-buildPythonPackage rec {
-  namePrefix = "";
-  name = "gandi-cli-${version}";
-  version = "0.19";
+buildPythonApplication rec {
+  pname = "gandi-cli";
+  version = "1.3";
 
   src = fetchFromGitHub {
-    sha256 = "0xbf97p75zl6sjxqcgmaa4p5rax2h6ixn8srwdr4rsx2zz9dpwgp";
-    rev = version;
-    repo = "gandi.cli";
     owner = "Gandi";
+    repo = "gandi.cli";
+    rev = version;
+    sha256 = "07i1y88j5awsw7qadk7gnmax8mi7vgh1nflnc8j54z53fjyamlcs";
   };
 
   propagatedBuildInputs = [ click ipy pyyaml requests ];
@@ -22,6 +21,6 @@ buildPythonPackage rec {
     description = "Command-line interface to the public Gandi.net API";
     homepage = http://cli.gandi.net/;
     license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ ckampka ];
   };
 }
-