about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-02-13 03:31:41 +0100
committerGitHub <noreply@github.com>2021-02-13 03:31:41 +0100
commit1b64cb09529478c0c0c5120af055520ca36770ae (patch)
treedaa307b44d49f6affda9dd12cf4efcc1533a2463 /pkgs/tools
parent1ca7cd20ace967b3740893231e1586069e223af5 (diff)
parent206e998c067ef9fd6c7e28fd8c7d9f504f3d8bb2 (diff)
downloadnixlib-1b64cb09529478c0c0c5120af055520ca36770ae.tar
nixlib-1b64cb09529478c0c0c5120af055520ca36770ae.tar.gz
nixlib-1b64cb09529478c0c0c5120af055520ca36770ae.tar.bz2
nixlib-1b64cb09529478c0c0c5120af055520ca36770ae.tar.lz
nixlib-1b64cb09529478c0c0c5120af055520ca36770ae.tar.xz
nixlib-1b64cb09529478c0c0c5120af055520ca36770ae.tar.zst
nixlib-1b64cb09529478c0c0c5120af055520ca36770ae.zip
Merge pull request #112950 from SuperSandro2000/fix-collection11
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/e2fsprogs/default.nix2
-rw-r--r--pkgs/tools/misc/smenu/default.nix17
-rw-r--r--pkgs/tools/misc/thefuck/default.nix16
3 files changed, 13 insertions, 22 deletions
diff --git a/pkgs/tools/filesystems/e2fsprogs/default.nix b/pkgs/tools/filesystems/e2fsprogs/default.nix
index ffe716dceea2..154b0006663c 100644
--- a/pkgs/tools/filesystems/e2fsprogs/default.nix
+++ b/pkgs/tools/filesystems/e2fsprogs/default.nix
@@ -71,5 +71,7 @@ stdenv.mkDerivation rec {
     license = licenses.gpl2;
     platforms = platforms.unix;
     maintainers = [ maintainers.eelco ];
+    # imager.c:70:2: error: unknown type name 'loff_t'; did you mean 'off_t'?
+    broken = stdenv.isDarwin;
   };
 }
diff --git a/pkgs/tools/misc/smenu/default.nix b/pkgs/tools/misc/smenu/default.nix
index dbfb5fb1cf82..1d1ed78b2faf 100644
--- a/pkgs/tools/misc/smenu/default.nix
+++ b/pkgs/tools/misc/smenu/default.nix
@@ -5,25 +5,24 @@ stdenv.mkDerivation rec {
   pname = "smenu";
 
   src = fetchFromGitHub {
-    owner  = "p-gen";
-    repo   = "smenu";
-    rev    = "v${version}";
+    owner = "p-gen";
+    repo = "smenu";
+    rev = "v${version}";
     sha256 = "1p8y1fgrfb7jxmv5ycvvnqaz7ghdi50paisgzk71169fqwp1crfa";
   };
 
   buildInputs = [ ncurses ];
 
   meta = with lib; {
-    homepage        = "https://github.com/p-gen/smenu";
-    description     = "Terminal selection utility";
+    homepage = "https://github.com/p-gen/smenu";
+    description = "Terminal selection utility";
     longDescription = ''
       Terminal utility that allows you to use words coming from the standard
       input to create a nice selection window just below the cursor. Once done,
       your selection will be sent to standard output.
     '';
-    license     = licenses.gpl2;
-    maintainers = [ maintainers.matthiasbeyer ];
-    platforms   = platforms.unix;
+    license = licenses.gpl2Only;
+    maintainers = with maintainers; [ matthiasbeyer SuperSandro2000 ];
+    platforms = platforms.unix;
   };
 }
-
diff --git a/pkgs/tools/misc/thefuck/default.nix b/pkgs/tools/misc/thefuck/default.nix
index d26c750a0c76..ff6a22cef8eb 100644
--- a/pkgs/tools/misc/thefuck/default.nix
+++ b/pkgs/tools/misc/thefuck/default.nix
@@ -1,6 +1,6 @@
 { lib, fetchFromGitHub, buildPythonApplication
 , colorama, decorator, psutil, pyte, six
-, pytest, pytest-mock
+, go, mock, pytestCheckHook, pytest-mock
 }:
 
 buildPythonApplication rec {
@@ -16,22 +16,12 @@ buildPythonApplication rec {
 
   propagatedBuildInputs = [ colorama decorator psutil pyte six ];
 
-  checkInputs = [ pytest pytest-mock ];
-
-  checkPhase = ''
-    export HOME=$TMPDIR
-    export LANG=en_US.UTF-8
-    export XDG_CACHE_HOME=$TMPDIR/cache
-    export XDG_CONFIG_HOME=$TMPDIR/config
-    py.test
-  '';
-
-  doCheck = false; # The above is only enough for tests to pass outside the sandbox.
+  checkInputs = [ go mock pytestCheckHook pytest-mock ];
 
   meta = with lib; {
     homepage = "https://github.com/nvbn/thefuck";
     description = "Magnificent app which corrects your previous console command";
     license = licenses.mit;
-    maintainers = with maintainers; [ ma27 ];
+    maintainers = with maintainers; [ ma27 SuperSandro2000 ];
   };
 }