about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAaron Andersen <aaron@fosslib.net>2019-07-19 20:45:27 -0400
committerGitHub <noreply@github.com>2019-07-19 20:45:27 -0400
commit1af592d65fb3f73c536c520e990314e1ad096258 (patch)
treeba2694776bcfb84c712009944f8e709c241135fc /pkgs/tools
parent1b6d404bfecdc8f2cbb83a3f204c0e1f61ea0501 (diff)
parent5d053d83339da54c898f6c3de83fef52a9c39837 (diff)
downloadnixlib-1af592d65fb3f73c536c520e990314e1ad096258.tar
nixlib-1af592d65fb3f73c536c520e990314e1ad096258.tar.gz
nixlib-1af592d65fb3f73c536c520e990314e1ad096258.tar.bz2
nixlib-1af592d65fb3f73c536c520e990314e1ad096258.tar.lz
nixlib-1af592d65fb3f73c536c520e990314e1ad096258.tar.xz
nixlib-1af592d65fb3f73c536c520e990314e1ad096258.tar.zst
nixlib-1af592d65fb3f73c536c520e990314e1ad096258.zip
Merge pull request #64705 from MetaDark/protontricks
protontricks: init at 1.2.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/package-management/protontricks/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/tools/package-management/protontricks/default.nix b/pkgs/tools/package-management/protontricks/default.nix
new file mode 100644
index 000000000000..ae8dfc590750
--- /dev/null
+++ b/pkgs/tools/package-management/protontricks/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, lib, buildPythonApplication, fetchFromGitHub
+, vdf, wine, winetricks, zenity
+}:
+
+buildPythonApplication rec {
+  pname = "protontricks";
+  version = "1.2.3";
+
+  src = fetchFromGitHub {
+    owner = "Matoking";
+    repo = pname;
+    rev = version;
+    sha256 = "1v7bgr1rkm8j99s5bv45cslw01qcx8i8zb6ysfrb53qz86zgkgsn";
+  };
+
+  propagatedBuildInputs = [ vdf ];
+
+  # The wine install shipped with Proton must run under steam's
+  # chrootenv, but winetricks and zenity break when running under
+  # it. See https://github.com/NixOS/nix/issues/902.
+  #
+  # The current workaround is to use wine from nixpkgs
+  makeWrapperArgs = [
+    "--set STEAM_RUNTIME 0"
+    "--set-default WINE ${wine}/bin/wine"
+    "--set-default WINESERVER ${wine}/bin/wineserver"
+    "--prefix PATH : ${lib.makeBinPath [
+      (winetricks.override { inherit wine; })
+      zenity
+    ]}"
+  ];
+
+  meta = with stdenv.lib; {
+    description = "A simple wrapper for running Winetricks commands for Proton-enabled games";
+    homepage = https://github.com/Matoking/protontricks;
+    license = licenses.gpl3;
+    platforms = with platforms; linux;
+    maintainers = with maintainers; [ metadark ];
+  };
+}