about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJaka Hudoklin <offlinehacker@users.noreply.github.com>2019-07-13 21:40:56 +0200
committerGitHub <noreply@github.com>2019-07-13 21:40:56 +0200
commit1ad69896552d88afc6f41cc7f0ddc392d8fff5fd (patch)
treeecd678f44759e0194fbe143a9fcc70e958ca32e1 /pkgs/tools
parent8951505dc960788020aeb7ee4b355343f1789631 (diff)
parent95f13ee4ea58025dad92fa29e8254ea345de344a (diff)
downloadnixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.tar
nixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.tar.gz
nixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.tar.bz2
nixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.tar.lz
nixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.tar.xz
nixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.tar.zst
nixlib-1ad69896552d88afc6f41cc7f0ddc392d8fff5fd.zip
Merge pull request #62698 from dtzWill/update/fakechroot-2.20.1
fakechroot: 2.19 -> 2.20.1, prefer patch and official source over "fork"
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/fakechroot/default.nix27
1 files changed, 19 insertions, 8 deletions
diff --git a/pkgs/tools/system/fakechroot/default.nix b/pkgs/tools/system/fakechroot/default.nix
index 25470af9bb30..77ba6689b0d4 100644
--- a/pkgs/tools/system/fakechroot/default.nix
+++ b/pkgs/tools/system/fakechroot/default.nix
@@ -1,17 +1,28 @@
-{ stdenv, fetchFromGitHub, autoreconfHook, perl }:
+{ stdenv, fetchFromGitHub, fetchpatch, autoreconfHook, perl }:
 
 stdenv.mkDerivation rec {
-  name = "fakechroot-${version}";
-  version = "2.19";
+  pname = "fakechroot";
+  version = "2.20.1";
 
-  # TODO: move back to mainline once https://github.com/dex4er/fakechroot/pull/46 is merged
   src = fetchFromGitHub {
-    owner  = "copumpkin";
-    repo   = "fakechroot";
-    rev    = "dcc0cfe3941e328538f9e62b2c0b15430d393ec1";
-    sha256 = "1ls3y97qqfcfd3z0balz94xq1gskfk04pg85x6b7wjw8dm4030qd";
+    owner  = "dex4er";
+    repo   = pname;
+    rev    = version;
+    sha256 = "0xgnwazrmrg4gm30xjxdn6sx3lhqvxahrh6gmy3yfswxc30pmg86";
   };
 
+  # Use patch from https://github.com/dex4er/fakechroot/pull/46 , remove once merged!
+  # Courtesy of one of our own, @copumpkin!
+  patches = [
+    (fetchpatch {
+      url = "https://github.com/dex4er/fakechroot/pull/46/commits/dcc0cfe3941e328538f9e62b2c0b15430d393ec1.patch";
+      sha256 = "1mk8j2njd94s7vf2wggi08xxxzx8dxrvdricl9cbspvkyp715w2m";
+      # Don't bother trying to reconcile conflicts for NEWS entries, as they will continue to occur
+      # and are uninteresting as well as unimportant for our purposes (since NEWS never leaves the build env).
+      excludes = [ "NEWS.md" ];
+    })
+  ];
+
   nativeBuildInputs = [ autoreconfHook ];
   buildInputs = [ perl ];