about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-03-27 10:55:12 +0100
committerGitHub <noreply@github.com>2018-03-27 10:55:12 +0100
commit1a44de831a339771be5a8f804a5cea3a2b2b88d9 (patch)
tree8a108a9c1e1760ee38983e5c98d6c60ad38ff471 /pkgs/tools
parent00a43001d44b48ca239aeb4292a8609cdc228118 (diff)
parentd74bcbc8ad0d683a368fde8ec5ad5ae168989199 (diff)
downloadnixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.tar
nixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.tar.gz
nixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.tar.bz2
nixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.tar.lz
nixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.tar.xz
nixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.tar.zst
nixlib-1a44de831a339771be5a8f804a5cea3a2b2b88d9.zip
Merge pull request #37597 from lejonet/ceph-#36622
ceph: Add makeWrapper to dependencies and nativeBuildInputs
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/ceph/generic.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/tools/filesystems/ceph/generic.nix b/pkgs/tools/filesystems/ceph/generic.nix
index 34becf80c8a9..4325a9355366 100644
--- a/pkgs/tools/filesystems/ceph/generic.nix
+++ b/pkgs/tools/filesystems/ceph/generic.nix
@@ -5,7 +5,7 @@
 , openldap, lttngUst
 , babeltrace, gperf
 , cunit, snappy
-, rocksdb
+, rocksdb, makeWrapper
 
 # Optional Dependencies
 , yasm ? null, fcgi ? null, expat ? null
@@ -96,6 +96,7 @@ let
     ps.pecan
     ps.prettytable
     ps.webob
+    ps.cherrypy
 	]);
 
 in
@@ -113,7 +114,7 @@ stdenv.mkDerivation {
 
   nativeBuildInputs = [
     cmake
-    pkgconfig which git python2Packages.wrapPython
+    pkgconfig which git python2Packages.wrapPython makeWrapper
     (ensureNewerSourcesHook { year = "1980"; })
   ];
   
@@ -158,6 +159,7 @@ stdenv.mkDerivation {
 
   postFixup = ''
     wrapPythonPrograms
+    wrapProgram $out/bin/ceph-mgr --set PYTHONPATH $out/${python2Packages.python.sitePackages}
   '';
 
   enableParallelBuilding = true;