about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPierre Bourdon <delroth@gmail.com>2019-09-21 03:45:15 +0200
committerPierre Bourdon <delroth@gmail.com>2019-09-21 03:46:57 +0200
commit18b607b71b061e4468d1e089b70e12db50a51d5a (patch)
tree84b2264ca1af869312d81697e59f9ec9d138361d /pkgs/tools
parent444597102572092c8ed50f33f0f08c7b4da9c6ec (diff)
downloadnixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.tar
nixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.tar.gz
nixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.tar.bz2
nixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.tar.lz
nixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.tar.xz
nixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.tar.zst
nixlib-18b607b71b061e4468d1e089b70e12db50a51d5a.zip
zbar: disable Qt assertions
Greatly decreases zbar-lib transitive closure size: assertion messages
contain paths to Qt header files, causing zbar-lib to depend on
qtbase-dev.

The Qt specific mkDerivation normally does this automatically, but we
can't use it here due to having only a small part of the project being
Qt related.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/zbar/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/tools/graphics/zbar/default.nix b/pkgs/tools/graphics/zbar/default.nix
index cb5ea25211cd..6423a84badc6 100644
--- a/pkgs/tools/graphics/zbar/default.nix
+++ b/pkgs/tools/graphics/zbar/default.nix
@@ -50,6 +50,9 @@ stdenv.mkDerivation rec {
     qtx11extras
   ];
 
+  # Disable assertions which include -dev QtBase file paths.
+  NIX_CFLAGS_COMPILE = [ "-DQT_NO_DEBUG" ];
+
   configureFlags = [
     "--without-python"
   ] ++ (if enableDbus then [