about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorBart Brouns <bart@magnetophon.nl>2020-06-11 14:39:48 +0200
committerBart Brouns <bart@magnetophon.nl>2020-06-11 18:41:17 +0200
commit1683a5f146344d97d738f696997e587452c817a7 (patch)
tree67c0b7202dc2399f30c7e64f08e61dc9a0b71519 /pkgs/tools
parent955701709f8fff53fb0e9b09926b82f91b2f53c8 (diff)
downloadnixlib-1683a5f146344d97d738f696997e587452c817a7.tar
nixlib-1683a5f146344d97d738f696997e587452c817a7.tar.gz
nixlib-1683a5f146344d97d738f696997e587452c817a7.tar.bz2
nixlib-1683a5f146344d97d738f696997e587452c817a7.tar.lz
nixlib-1683a5f146344d97d738f696997e587452c817a7.tar.xz
nixlib-1683a5f146344d97d738f696997e587452c817a7.tar.zst
nixlib-1683a5f146344d97d738f696997e587452c817a7.zip
Revert "dtrx: remove p7zip, since it's unsafe"
This reverts commit 9b3ca0c6149bb222da800a89cf9b6b2bc838dc4c.
p7zip is now switched to a maintained fork
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/compression/dtrx/default.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/pkgs/tools/compression/dtrx/default.nix b/pkgs/tools/compression/dtrx/default.nix
index edca969a1e84..81a446066d97 100644
--- a/pkgs/tools/compression/dtrx/default.nix
+++ b/pkgs/tools/compression/dtrx/default.nix
@@ -1,18 +1,15 @@
 {stdenv, lib, fetchurl, pythonPackages
-, gnutar, unzip, lhasa, rpm, binutils, cpio, gzip, cabextract, unrar, unshield
+, gnutar, unzip, lhasa, rpm, binutils, cpio, gzip, p7zip, cabextract, unrar, unshield
 , bzip2, xz, lzip
-# unsafe:
-# ,p7zip
-# unzip is no longer handled by p7zip, since it's unsafe
-, unzipSupport ? true
+# unzip is handled by p7zip
+, unzipSupport ? false
 , unrarSupport ? false }:
 
 let
-  # p7zip
-  archivers = lib.makeBinPath ([ gnutar lhasa rpm binutils cpio gzip cabextract unshield ]
-                               ++ lib.optional (unzipSupport) unzip
-                               ++ lib.optional (unrarSupport) unrar
-                               ++ [ bzip2 xz lzip ]);
+  archivers = lib.makeBinPath ([ gnutar lhasa rpm binutils cpio gzip p7zip cabextract unshield ]
+  ++ lib.optional (unzipSupport) unzip
+  ++ lib.optional (unrarSupport) unrar
+  ++ [ bzip2 xz lzip ]);
 
 in pythonPackages.buildPythonApplication rec {
   pname = "dtrx";