about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAaron Andersen <aaron@fosslib.net>2019-05-26 12:27:51 -0400
committerGitHub <noreply@github.com>2019-05-26 12:27:51 -0400
commit1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3 (patch)
treea5d21d5902b8c5cc64ef2a76de916e4b93c2d7a1 /pkgs/tools
parenta3cd1b8fdab8dbe7e2073e3312e4a3d3f8477d81 (diff)
parent8ca86c757db97c72fff81e8b894642c1e89df856 (diff)
downloadnixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.tar
nixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.tar.gz
nixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.tar.bz2
nixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.tar.lz
nixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.tar.xz
nixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.tar.zst
nixlib-1316e4a7457d93ff2ae1ac3e65a31e4175ab38f3.zip
Merge pull request #61998 from marius851000/ytcc
ytcc: init at 1.8.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/ytcc/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/networking/ytcc/default.nix b/pkgs/tools/networking/ytcc/default.nix
new file mode 100644
index 000000000000..137a9216df00
--- /dev/null
+++ b/pkgs/tools/networking/ytcc/default.nix
@@ -0,0 +1,25 @@
+{ lib, python3Packages, fetchFromGitHub, gettext }:
+
+python3Packages.buildPythonApplication rec {
+  pname = "ytcc";
+  version = "1.8.1";
+
+  src = fetchFromGitHub {
+    owner = "woefe";
+    repo = "ytcc";
+    rev = "v${version}";
+    sha256 = "080p145j5pg8db88kb0y3x1pfc3v4aj3w68pdihlmi68dhjdr7i7";
+  };
+
+  doCheck = false; # try to access /homeless-shelter
+  propagatedBuildInputs = with python3Packages; [ feedparser lxml sqlalchemy youtube-dl ];
+
+  nativeBuildInputs = [ gettext ];
+
+  meta = {
+    description = "Command Line tool to keep track of your favourite YouTube channels without signing up for a Google account";
+    homepage = "https://github.com/woefe/ytcc";
+    license = lib.licenses.gpl3;
+    maintainers = with lib.maintainers; [ marius851000 ];
+  };
+}