about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-11-17 20:41:39 +0000
committerGitHub <noreply@github.com>2018-11-17 20:41:39 +0000
commit1156427ac06b017c5589d2661c9a55032f705e3f (patch)
tree3177cfb60187c055043ec25dfe4c2e7d5c4266a6 /pkgs/tools
parentf97d9d1e9e4e3828d74f006f42ab92d36cc294fb (diff)
parent88eb07017fdec25b3747b04c455cdc2258171ef4 (diff)
downloadnixlib-1156427ac06b017c5589d2661c9a55032f705e3f.tar
nixlib-1156427ac06b017c5589d2661c9a55032f705e3f.tar.gz
nixlib-1156427ac06b017c5589d2661c9a55032f705e3f.tar.bz2
nixlib-1156427ac06b017c5589d2661c9a55032f705e3f.tar.lz
nixlib-1156427ac06b017c5589d2661c9a55032f705e3f.tar.xz
nixlib-1156427ac06b017c5589d2661c9a55032f705e3f.tar.zst
nixlib-1156427ac06b017c5589d2661c9a55032f705e3f.zip
Merge pull request #50513 from layer-3-communications/add-openconnect-pa
Add openconnect pa
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/openconnect_pa/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/tools/networking/openconnect_pa/default.nix b/pkgs/tools/networking/openconnect_pa/default.nix
new file mode 100644
index 000000000000..d261e5717052
--- /dev/null
+++ b/pkgs/tools/networking/openconnect_pa/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchFromGitHub, pkgconfig, vpnc, openssl ? null, gnutls ? null, gmp, libxml2, stoken, zlib, autoreconfHook } :
+
+assert (openssl != null) == (gnutls == null);
+
+stdenv.mkDerivation rec {
+  version = "unstable-2018-10-08";
+  name = "openconnect_pa-${version}";
+  
+  outputs = [ "out" "dev" ];
+
+  src = fetchFromGitHub {
+    owner = "dlenski";
+    repo = "openconnect";
+    rev = "e5fe063a087385c5b157ad7a9a3fa874181f6e3b";
+    sha256 = "0ywacqs3nncr2gpjjcz2yc9c6v4ifjssh0vb07h0qff06whqhdax"; 
+  };
+
+  preConfigure = ''
+      export PKG_CONFIG=${pkgconfig}/bin/pkg-config
+      export LIBXML2_CFLAGS="-I ${libxml2.dev}/include/libxml2"
+      export LIBXML2_LIBS="-L${libxml2.out}/lib -lxml2"
+  '';
+
+  configureFlags = [
+    "--with-vpnc-script=${vpnc}/etc/vpnc/vpnc-script"
+    "--disable-nls"
+    "--without-openssl-version-check"
+  ];
+
+  nativeBuildInputs = [ pkgconfig autoreconfHook ];
+  propagatedBuildInputs = [ vpnc openssl gnutls gmp libxml2 stoken zlib ];
+  
+  meta = with stdenv.lib; {
+    description = "OpenConnect client extended to support Palo Alto Networks' GlobalProtect VPN";
+    homepage = https://github.com/dlenski/openconnect/;
+    license = licenses.lgpl21;
+    maintainers = with maintainers; [ chessai ];
+    platforms = platforms.linux;
+  };
+}