about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2014-03-20 13:18:51 -0500
committerAustin Seipp <aseipp@pobox.com>2014-03-20 13:18:51 -0500
commit0c3bb487c3d64fe445865dbcad2fced0d8dd8c09 (patch)
treea974e9ba7f2a10ea21ae84dbee5f4005f12c1590 /pkgs/tools
parent042f85cdd0586da8b7649f48389e6ac607c8b416 (diff)
downloadnixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.tar
nixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.tar.gz
nixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.tar.bz2
nixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.tar.lz
nixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.tar.xz
nixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.tar.zst
nixlib-0c3bb487c3d64fe445865dbcad2fced0d8dd8c09.zip
ssdeep: version 2.10
Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/ssdeep/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/tools/security/ssdeep/default.nix b/pkgs/tools/security/ssdeep/default.nix
new file mode 100644
index 000000000000..66fdedc49063
--- /dev/null
+++ b/pkgs/tools/security/ssdeep/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name    = "ssdeep-${version}";
+  version = "2.10";
+
+  src = fetchurl {
+    url    = "mirror://sourceforge/ssdeep/${name}.tar.gz";
+    sha256 = "1p7dgchq8hgadnxz5qh95ay17k5j74l4qyd15wspc54lb603p2av";
+  };
+
+  postFixup = ''
+    patchelf --set-rpath "$(patchelf --print-rpath $out/bin/ssdeep):$out/lib" $out/bin/ssdeep
+  '';
+
+  meta = {
+    description = "A program for calculating fuzzy hashes";
+    homepage    = "http://www.ssdeep.sf.net";
+    license     = stdenv.lib.licenses.gpl2;
+    platforms   = stdenv.lib.platforms.unix;
+    maintainers = [ stdenv.lib.maintainers.thoughtpolice ];
+  };
+}