about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2018-10-08 17:14:38 +0800
committerPeter Hoeg <peter@hoeg.com>2018-10-08 17:14:38 +0800
commit0932acc62227045ffafc770dc2e0b231a9f3dfe2 (patch)
treefa37633340aac23f252322e3236d3c7303abe471 /pkgs/tools
parent0a7e258012b60cbe530a756f09a4f2516786d370 (diff)
downloadnixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.tar
nixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.tar.gz
nixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.tar.bz2
nixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.tar.lz
nixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.tar.xz
nixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.tar.zst
nixlib-0932acc62227045ffafc770dc2e0b231a9f3dfe2.zip
fbv: init at 1.0b
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/fbv/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/graphics/fbv/default.nix b/pkgs/tools/graphics/fbv/default.nix
new file mode 100644
index 000000000000..c7fab1710672
--- /dev/null
+++ b/pkgs/tools/graphics/fbv/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, getopt, libjpeg, libpng12, libungif }:
+
+stdenv.mkDerivation rec {
+  name = "fbv-1.0b";
+
+  src = fetchurl {
+    url = "http://s-tech.elsat.net.pl/fbv/${name}.tar.gz";
+    sha256 = "0g5b550vk11l639y8p5sx1v1i6ihgqk0x1hd0ri1bc2yzpdbjmcv";
+  };
+
+  buildInputs = [ getopt libjpeg libpng12 libungif ];
+
+  enableParallelBuilding = true;
+
+  preInstall = ''
+    mkdir -p $out/{bin,man/man1}
+  '';
+
+  meta = with stdenv.lib; {
+    description = "View pictures on a linux framebuffer device";
+    homepage = http://s-tech.elsat.net.pl/fbv/;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ peterhoeg ];
+  };
+}