about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPeter Romfeld <peter.romfeld.hk@gmail.com>2018-11-02 16:05:54 +0800
committerPeter Romfeld <peter.romfeld.hk@gmail.com>2018-11-28 00:45:45 +0800
commit08699733bbf38cb2ab587688db727e0fd8b83cce (patch)
treee0044055e30ad775b10647fb04690cd4be070425 /pkgs/tools
parent6753b2c6c1515411e3bf731b3c6a1413093a02e1 (diff)
downloadnixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.tar
nixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.tar.gz
nixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.tar.bz2
nixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.tar.lz
nixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.tar.xz
nixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.tar.zst
nixlib-08699733bbf38cb2ab587688db727e0fd8b83cce.zip
pulumi: init at 0.16.2
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/pulumi/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/tools/admin/pulumi/default.nix b/pkgs/tools/admin/pulumi/default.nix
new file mode 100644
index 000000000000..b24b88fa96a2
--- /dev/null
+++ b/pkgs/tools/admin/pulumi/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchurl }:
+
+let
+
+  version = "0.16.2";
+
+  # switch the dropdown to “manual” on https://pulumi.io/quickstart/install.html # TODO: update script
+  pulumiArchPackage = {
+    "x86_64-linux" = {
+      url = "https://get.pulumi.com/releases/sdk/pulumi-v${version}-linux-x64.tar.gz";
+      sha256 = "16qgy2pj3xkf1adi3882fpsl99jwsm19111fi5vzh1xqf39sg549";
+    };
+    "x86_64-darwin" = {
+      url = "https://get.pulumi.com/releases/sdk/pulumi-v${version}-darwin-x64.tar.gz";
+      sha256 = "18ck9khspa0x798bdlwk8dzylbsq7s35xmla8yasd9qqlab1yy1a";
+    };
+  };
+
+in stdenv.mkDerivation rec {
+  inherit version;
+  name = "pulumi-${version}";
+
+  src = fetchurl pulumiArchPackage.${stdenv.hostPlatform.system};
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp * $out/bin/
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://pulumi.io/;
+    description = "Pulumi is a cloud development platform that makes creating cloud programs easy and productive";
+    license = with licenses; [ asl20 ];
+    platforms = builtins.attrNames pulumiArchPackage;
+    maintainers = with maintainers; [
+      peterromfeldhk
+    ];
+  };
+}