about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2019-09-05 12:27:00 -0700
committerGitHub <noreply@github.com>2019-09-05 12:27:00 -0700
commit0213ccf6243a63c34b72e6a2ef4d9140a4d86540 (patch)
tree90c0b11d1c301bc96bc21b2c7ca08b580e3205a0 /pkgs/tools
parent5aa576026179cc54cdc9d53a47b3eb0b1ef483d2 (diff)
parentd64cdba5b4b4fef528ad640495c392621a197393 (diff)
downloadnixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.tar
nixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.tar.gz
nixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.tar.bz2
nixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.tar.lz
nixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.tar.xz
nixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.tar.zst
nixlib-0213ccf6243a63c34b72e6a2ef4d9140a4d86540.zip
Merge pull request #67894 from marzipankaiser/caffeine-ng
caffeine-ng: use python3 and some other improvements
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/caffeine-ng/default.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/pkgs/tools/X11/caffeine-ng/default.nix b/pkgs/tools/X11/caffeine-ng/default.nix
index 57f32ed82250..b54a7303ff87 100644
--- a/pkgs/tools/X11/caffeine-ng/default.nix
+++ b/pkgs/tools/X11/caffeine-ng/default.nix
@@ -1,23 +1,28 @@
 { gdk-pixbuf, glib, gobject-introspection, gtk3, lib, libnotify,
-  pythonPackages, wrapGAppsHook
+  python3Packages, wrapGAppsHook
 }:
 
-pythonPackages.buildPythonApplication rec {
+python3Packages.buildPythonApplication rec {
   pname = "caffeine-ng";
   version = "3.4.2";
 
-  src = pythonPackages.fetchPypi{
+  src = python3Packages.fetchPypi{
     inherit pname version;
     sha256="05k8smjlfjcccgmp8qi04l7106k46fs4p8fl5bdqqjwv6pwl7y4w";
   };
 
   nativeBuildInputs = [ wrapGAppsHook glib ];
-  buildInputs = [ gdk-pixbuf gobject-introspection libnotify gtk3 ];
-  pythonPath = with pythonPackages; [
+  buildInputs = [ 
+    gdk-pixbuf gobject-introspection libnotify gtk3 
+    python3Packages.setuptools_scm
+  ];
+  pythonPath = with python3Packages; [
     dbus-python docopt ewmh pygobject3 pyxdg
-    setproctitle setuptools setuptools_scm wheel
+    setproctitle 
   ];
 
+  doCheck = false; # There are no tests.
+
   postBuild = ''
     mkdir -p $out/share
     cp -r share $out/