about summary refs log tree commit diff
path: root/pkgs/test
diff options
context:
space:
mode:
authormaralorn <mail@maralorn.de>2024-01-01 19:16:21 +0100
committermaralorn <mail@maralorn.de>2024-01-01 19:16:21 +0100
commit5518af0a558dde9ce869098799be461bc74485ab (patch)
treeb7f80117fa2cb57fdd94f5c4c3faba054d7e4460 /pkgs/test
parent7b4156eddac0142fc02dba8f88c958f71e9d0baa (diff)
downloadnixlib-5518af0a558dde9ce869098799be461bc74485ab.tar
nixlib-5518af0a558dde9ce869098799be461bc74485ab.tar.gz
nixlib-5518af0a558dde9ce869098799be461bc74485ab.tar.bz2
nixlib-5518af0a558dde9ce869098799be461bc74485ab.tar.lz
nixlib-5518af0a558dde9ce869098799be461bc74485ab.tar.xz
nixlib-5518af0a558dde9ce869098799be461bc74485ab.tar.zst
nixlib-5518af0a558dde9ce869098799be461bc74485ab.zip
haskellPackages: Fix eval errors
Diffstat (limited to 'pkgs/test')
-rw-r--r--pkgs/test/haskell/incremental/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/test/haskell/incremental/default.nix b/pkgs/test/haskell/incremental/default.nix
index 59bd5e491e95..c7bd43b11af6 100644
--- a/pkgs/test/haskell/incremental/default.nix
+++ b/pkgs/test/haskell/incremental/default.nix
@@ -3,13 +3,13 @@
 # See: https://www.haskellforall.com/2022/12/nixpkgs-support-for-incremental-haskell.html
 # See: https://felixspringer.xyz/homepage/blog/incrementalHaskellBuildsWithNix
 
-{ haskell, lib }:
+{ haskell, haskellPackages, lib }:
 
 let
   inherit (haskell.lib.compose) overrideCabal;
 
   # Incremental builds work with GHC >=9.4.
-  temporary = haskell.haskellPackages.temporary;
+  temporary = haskellPackages.temporary;
 
   # This will do a full build of `temporary`, while writing the intermediate build products
   # (compiled modules, etc.) to the `intermediates` output.