about summary refs log tree commit diff
path: root/pkgs/test
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2023-01-25 11:54:02 +0100
committerRobert Hensing <robert@roberthensing.nl>2023-01-29 09:51:54 +0100
commit2d4e78fb8bd3420d31879f5669160b1a62d47fb0 (patch)
tree3b3e7b87664f2471124dac9caf8681943633616b /pkgs/test
parentb576b17fb00af05968a0ccaddf7ee63857d8d5e2 (diff)
downloadnixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.tar
nixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.tar.gz
nixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.tar.bz2
nixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.tar.lz
nixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.tar.xz
nixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.tar.zst
nixlib-2d4e78fb8bd3420d31879f5669160b1a62d47fb0.zip
tests.pkg-configPackages: Copy meta attributes for licensing concerns
Diffstat (limited to 'pkgs/test')
-rw-r--r--pkgs/test/pkg-config-packages.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/test/pkg-config-packages.nix b/pkgs/test/pkg-config-packages.nix
index 2d14d9402f0e..be046c8cacca 100644
--- a/pkgs/test/pkg-config-packages.nix
+++ b/pkgs/test/pkg-config-packages.nix
@@ -43,6 +43,24 @@ let
     nativeBuildInputs = [ pkg-config ];
     buildInputs = [ pkg ];
     inherit moduleName;
+    meta = {
+      description = "Test whether ${pkg.name} exposes pkg-config module ${moduleName}";
+    }
+    # Make sure licensing info etc is preserved, as this is a concern for e.g. cache.nixos.org,
+    # as hydra can't check this meta info in dependencies.
+    # The test itself is just Nixpkgs, with MIT license.
+    // builtins.intersectAttrs
+        {
+          available = throw "unused";
+          broken = throw "unused";
+          insecure = throw "unused";
+          license = throw "unused";
+          maintainers = throw "unused";
+          platforms = throw "unused";
+          unfree = throw "unused";
+          unsupported = throw "unused";
+        }
+        pkg.meta;
   } ''
     echo "checking pkg-config module $moduleName in $buildInputs"
     set +e