about summary refs log tree commit diff
path: root/pkgs/test/incrementalBuild/hello-additionalFile.patch
diff options
context:
space:
mode:
authorMartin Messer <martin.messer@cyberus-technology.de>2022-04-07 16:28:20 +0200
committerMartin Messer <martin.messer@cyberus-technology.de>2023-12-07 16:38:48 +0100
commit17e88c2890068e944c61dbaf7493ae12417b8944 (patch)
tree8a6c526ab1391a63dc10a29d59d7539344ae9594 /pkgs/test/incrementalBuild/hello-additionalFile.patch
parent1cd6b7fdc37cdc7a4a31c87aa31e4ebf5ed930c8 (diff)
downloadnixlib-17e88c2890068e944c61dbaf7493ae12417b8944.tar
nixlib-17e88c2890068e944c61dbaf7493ae12417b8944.tar.gz
nixlib-17e88c2890068e944c61dbaf7493ae12417b8944.tar.bz2
nixlib-17e88c2890068e944c61dbaf7493ae12417b8944.tar.lz
nixlib-17e88c2890068e944c61dbaf7493ae12417b8944.tar.xz
nixlib-17e88c2890068e944c61dbaf7493ae12417b8944.tar.zst
nixlib-17e88c2890068e944c61dbaf7493ae12417b8944.zip
checkpointedBuild: add checkpointed build test based on pkgs hello
Diffstat (limited to 'pkgs/test/incrementalBuild/hello-additionalFile.patch')
-rw-r--r--pkgs/test/incrementalBuild/hello-additionalFile.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/pkgs/test/incrementalBuild/hello-additionalFile.patch b/pkgs/test/incrementalBuild/hello-additionalFile.patch
new file mode 100644
index 000000000000..31fbe034909e
--- /dev/null
+++ b/pkgs/test/incrementalBuild/hello-additionalFile.patch
@@ -0,0 +1,62 @@
+diff --git a/Makefile.in b/Makefile.in
+index 0805eda..77b000c 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -227,7 +227,7 @@ am_lib_libhello_a_OBJECTS = lib/c-ctype.$(OBJEXT) \
+ 	lib/quotearg.$(OBJEXT) lib/strnlen1.$(OBJEXT) \
+ 	lib/unistd.$(OBJEXT) lib/wctype-h.$(OBJEXT) \
+ 	lib/xmalloc.$(OBJEXT) lib/xalloc-die.$(OBJEXT) \
+-	lib/xstrndup.$(OBJEXT)
++	lib/xstrndup.$(OBJEXT) src/additionalFile.$(OBJEXT)
+ lib_libhello_a_OBJECTS = $(am_lib_libhello_a_OBJECTS)
+ am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(infodir)" \
+ 	"$(DESTDIR)$(man1dir)"
+@@ -1380,7 +1380,7 @@ lib_libhello_a_SOURCES = lib/c-ctype.h lib/c-ctype.c lib/c-strcase.h \
+ 	lib/gettext.h lib/localcharset.h lib/localcharset.c \
+ 	lib/progname.h lib/progname.c lib/quotearg.c lib/strnlen1.h \
+ 	lib/strnlen1.c lib/unistd.c lib/wctype-h.c lib/xmalloc.c \
+-	lib/xalloc-die.c lib/xstrndup.h lib/xstrndup.c
++	lib/xalloc-die.c lib/xstrndup.h lib/xstrndup.c src/additionalFile.c
+ lib_libhello_a_LIBADD = $(gl_LIBOBJS)
+ lib_libhello_a_DEPENDENCIES = $(gl_LIBOBJS)
+ EXTRA_lib_libhello_a_SOURCES = lib/stripslash.c lib/error.c \
+diff --git a/src/additionalFile.c b/src/additionalFile.c
+new file mode 100644
+index 0000000..34d683d
+--- /dev/null
++++ b/src/additionalFile.c
+@@ -0,0 +1,6 @@
++#include "config.h"
++#include "system.h"
++
++int somefunc() {
++    return 0;
++}
+diff --git a/src/hello.c b/src/hello.c
+index 453962f..df67de2 100644
+--- a/src/hello.c
++++ b/src/hello.c
+@@ -57,7 +57,11 @@ main (int argc, char *argv[])
+ #endif
+ 
+   /* Having initialized gettext, get the default message. */
+-  greeting_msg = _("Hello, world!");
++  if (somefunc() == 0) {
++    greeting_msg = _("Hello, world!");
++  } else {
++    greeting_msg = _("Hello, incremental world!");
++  }
+ 
+   /* Even exiting has subtleties.  On exit, if any writes failed, change
+      the exit status.  The /dev/full device on GNU/Linux can be used for
+diff --git a/src/system.h b/src/system.h
+index d1acac2..935b955 100644
+--- a/src/system.h
++++ b/src/system.h
+@@ -42,4 +42,6 @@
+ /* Check for errors on write.  */
+ # include "closeout.h"
+ 
++int somefunc();
++
+ #endif /* HELLO_SYSTEM_H */