about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2020-05-15 18:56:17 -0500
committerGitHub <noreply@github.com>2020-05-15 18:56:17 -0500
commitfb35227b8cbfa9435ac4941ea147eed65ba517ae (patch)
tree024db66c0b886a54ec40fcfa387f812dbdf29c7f /pkgs/stdenv
parent282cb2f8d6ca4bbd18eacfa5ca8a05481def71fa (diff)
parent23ce1eed34c97df283ad85ab40b8b33a6a8818eb (diff)
downloadnixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.tar
nixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.tar.gz
nixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.tar.bz2
nixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.tar.lz
nixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.tar.xz
nixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.tar.zst
nixlib-fb35227b8cbfa9435ac4941ea147eed65ba517ae.zip
Merge pull request #87583 from Gaelan/single-llvm
stdenv-darwin: now with 50% less LLVM!
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 2d5a191fc32b..b69de041fd23 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -305,7 +305,7 @@ in rec {
       inherit
         gnumake gzip gnused bzip2 gawk ed xz patch bash python3
         ncurses libffi zlib gmp pcre gnugrep
-        coreutils findutils diffutils patchutils ninja;
+        coreutils findutils diffutils patchutils ninja libxml2;
 
       # Hack to make sure we don't link ncurses in bootstrap tools. The proper
       # solution is to avoid passing -L/nix-store/...-bootstrap-tools/lib,
@@ -319,7 +319,7 @@ in rec {
       llvmPackages_7 = super.llvmPackages_7 // (let
         tools = super.llvmPackages_7.tools.extend (llvmSelf: _: {
           clang-unwrapped = llvmPackages_7.clang-unwrapped.override { llvm = llvmSelf.llvm; };
-          llvm = llvmPackages_7.llvm.override { libxml2 = self.darwin.libxml2-nopython; };
+          llvm = llvmPackages_7.llvm.override { inherit libxml2; };
         });
         libraries = super.llvmPackages_7.libraries.extend (llvmSelf: _: {
           inherit (llvmPackages_7) libcxx libcxxabi compiler-rt;
@@ -330,9 +330,8 @@ in rec {
         inherit (darwin) dyld Libsystem libiconv locale;
 
         cctools = super.darwin.cctools.override { enableTapiSupport = false; };
-        libxml2-nopython = super.libxml2.override { pythonSupport = false; };
         CF = super.darwin.CF.override {
-          libxml2 = libxml2-nopython;
+          inherit libxml2;
           python3 = prevStage.python3;
         };
       };
@@ -417,9 +416,9 @@ in rec {
       gnugrep llvmPackages.clang-unwrapped llvmPackages.clang-unwrapped.lib patch pcre.out gettext
       binutils.bintools darwin.binutils darwin.binutils.bintools
       curl.out openssl.out libssh2.out nghttp2.lib libkrb5
-      cc.expand-response-params
+      cc.expand-response-params libxml2.out
     ]) ++ (with pkgs.darwin; [
-      dyld Libsystem CF cctools ICU libiconv locale libxml2-nopython.out
+      dyld Libsystem CF cctools ICU libiconv locale
     ]);
 
     overrides = lib.composeExtensions persistent (self: super: {