about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@viric.name>2012-12-27 15:19:23 +0000
committerLluís Batlle i Rossell <viric@viric.name>2012-12-27 15:19:23 +0000
commitee2f05d683cfdfe6169263d9185fbd0f76303d68 (patch)
treea8611f0cdd3a5716c52dec7be2defa88e55866c0 /pkgs/stdenv
parentc41881842b316c1e38e54b00bee1770f9eb5eb2c (diff)
downloadnixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.tar
nixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.tar.gz
nixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.tar.bz2
nixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.tar.lz
nixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.tar.xz
nixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.tar.zst
nixlib-ee2f05d683cfdfe6169263d9185fbd0f76303d68.zip
Removing unneeded changes in stdenvLinux, for the pi.
I had those changes from the time when I wanted to bootstrap
its stdenvLinux from armv5tel bootstrap-tools. But that
never worked.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index cae95615a446..bdf91e717cdf 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -203,23 +203,19 @@ rec {
       coreutils = bootstrapTools;
       libc = stdenvLinuxGlibc;
     };
-    overrides = pkgs: ({
+    overrides = pkgs: {
       glibc = stdenvLinuxGlibc;
       inherit (stdenvLinuxBoot1Pkgs) perl;
-    } // (if (platform ? name && platform.name != "raspberrypi") then {
       # Link GCC statically against GMP etc.  This makes sense because
       # these builds of the libraries are only used by GCC, so it
       # reduces the size of the stdenv closure.
-
-      # On raspberry pi we can't do that, because libgcc/libstdc++ are made
-      # without hardfp, and can't be linked with the new hardfp code in gcc.
       gmp = pkgs.gmp.override { stdenv = pkgs.makeStaticLibraries pkgs.stdenv; };
       mpfr = pkgs.mpfr.override { stdenv = pkgs.makeStaticLibraries pkgs.stdenv; };
       mpc = pkgs.mpc.override { stdenv = pkgs.makeStaticLibraries pkgs.stdenv; };
       isl = pkgs.isl.override { stdenv = pkgs.makeStaticLibraries pkgs.stdenv; };
       cloog = pkgs.cloog.override { stdenv = pkgs.makeStaticLibraries pkgs.stdenv; };
       ppl = pkgs.ppl.override { stdenv = pkgs.makeStaticLibraries pkgs.stdenv; };
-    } else {}));
+    };
     inherit fetchurl;
   };
 
@@ -240,8 +236,7 @@ rec {
       inherit (stdenvLinuxBoot3Pkgs) binutils;
       coreutils = bootstrapTools;
       libc = stdenvLinuxGlibc;
-      gcc = stdenvLinuxBoot3Pkgs.gcc.gcc.override (if platform.name == "raspberrypi" then
-	{ ppl = null; cloog = null; } else {});
+      gcc = stdenvLinuxBoot3Pkgs.gcc.gcc;
       name = "";
     };
     extraPath = [ stdenvLinuxBoot3Pkgs.xz ];