about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-11-07 13:37:02 -0600
committerGitHub <noreply@github.com>2018-11-07 13:37:02 -0600
commitc8aff961100a792fc67f2e9005d5812ebbec1cd5 (patch)
tree7f96e9a7615a0960fd99f1d6d59b6420ca1c54be /pkgs/stdenv
parent424c38b92a7f909c695f93a18f72d023acd59953 (diff)
parent2f2e635dd5431859a01bbbcae0493be90041d495 (diff)
downloadnixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.tar
nixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.tar.gz
nixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.tar.bz2
nixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.tar.lz
nixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.tar.xz
nixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.tar.zst
nixlib-c8aff961100a792fc67f2e9005d5812ebbec1cd5.zip
Merge pull request #49608 from matthewbauer/cross-patch-shebangs-2
Restore cross-patch-shebangs branch
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix8
-rw-r--r--pkgs/stdenv/generic/setup.sh8
2 files changed, 4 insertions, 12 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 5fb410b64ebd..d9b3c7dd29f0 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -278,8 +278,8 @@ in rec {
     # enables patchShebangs above. Unfortunately, patchShebangs ignores our $SHELL setting
     # and instead goes by $PATH, which happens to contain bootstrapTools. So it goes and
     # patches our shebangs back to point at bootstrapTools. This makes sure bash comes first.
-    extraNativeBuildInputs = with pkgs; [ xz pkgs.bash ];
-    extraBuildInputs = [ pkgs.darwin.CF ];
+    extraNativeBuildInputs = with pkgs; [ xz ];
+    extraBuildInputs = [ pkgs.darwin.CF pkgs.bash ];
     libcxx = pkgs.libcxx;
 
     extraPreHook = ''
@@ -335,8 +335,8 @@ in rec {
     };
   in with prevStage; stageFun 4 prevStage {
     shell = "${pkgs.bash}/bin/bash";
-    extraNativeBuildInputs = with pkgs; [ xz pkgs.bash ];
-    extraBuildInputs = [ pkgs.darwin.CF ];
+    extraNativeBuildInputs = with pkgs; [ xz ];
+    extraBuildInputs = [ pkgs.darwin.CF pkgs.bash ];
     libcxx = pkgs.libcxx;
 
     extraPreHook = ''
diff --git a/pkgs/stdenv/generic/setup.sh b/pkgs/stdenv/generic/setup.sh
index 8af369b1d17d..81c1725f1d19 100644
--- a/pkgs/stdenv/generic/setup.sh
+++ b/pkgs/stdenv/generic/setup.sh
@@ -257,17 +257,9 @@ shopt -s nullglob
 
 # Set up the initial path.
 PATH=
-HOST_PATH=
 for i in $initialPath; do
     if [ "$i" = / ]; then i=; fi
     addToSearchPath PATH "$i/bin"
-
-    # For backward compatibility, we add initial path to HOST_PATH so
-    # it can be used in auto patch-shebangs. Unfortunately this will
-    # not work with cross compilation.
-    if [ -z "${strictDeps-}" ]; then
-        addToSearchPath HOST_PATH "$i/bin"
-    fi
 done
 
 if (( "${NIX_DEBUG:-0}" >= 1 )); then