about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-10-13 18:01:31 +0000
committerGitHub <noreply@github.com>2023-10-13 18:01:31 +0000
commitc68d98e9d41f96cf3d591f8d5a7abfdb2b292799 (patch)
treebe6df5adcc1528f56a1204acff4eaf2cfd1cefb6 /pkgs/stdenv
parent68ba5fd2ed8be749cf1865ed9a71667dfda944a7 (diff)
parent4a7eb88e55f80623bb3ea4968ff4600814016ffb (diff)
downloadnixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.tar
nixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.tar.gz
nixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.tar.bz2
nixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.tar.lz
nixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.tar.xz
nixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.tar.zst
nixlib-c68d98e9d41f96cf3d591f8d5a7abfdb2b292799.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/adapters.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/stdenv/adapters.nix b/pkgs/stdenv/adapters.nix
index 170e569b8244..05aaaea4f105 100644
--- a/pkgs/stdenv/adapters.nix
+++ b/pkgs/stdenv/adapters.nix
@@ -202,7 +202,10 @@ rec {
       inherit bintools;
     };
     allowedRequisites =
-      lib.mapNullable (rs: rs ++ [ bintools pkgs.mold (lib.getLib pkgs.mimalloc) (lib.getLib pkgs.openssl) ]) (stdenv.allowedRequisites or null);
+      (lib.optional (stdenv.allowedRequisites or null != null) stdenv.allowedRequisites)
+        ++ [ bintools pkgs.mold ]
+        # need to `outputSpecified = false` to make getLib work
+        ++ (builtins.map (p: lib.getLib (p // { outputSpecified = false; })) pkgs.mold.buildInputs);
       # gcc >12.1.0 supports '-fuse-ld=mold'
       # the wrap ld above in bintools supports gcc <12.1.0 and shouldn't harm >12.1.0
     # https://github.com/rui314/mold#how-to-use