about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-05-21 14:51:02 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-06-22 17:52:27 -0400
commitc4ba2e3ef691c349bcce2b1e8b76a0bcd253544c (patch)
treec83f3c3b37e42462fc7b60c8bfa39f856f569c38 /pkgs/stdenv
parent8f970d09fe8e895b6bb7dbf52f80411a45504b19 (diff)
downloadnixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.tar
nixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.tar.gz
nixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.tar.bz2
nixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.tar.lz
nixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.tar.xz
nixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.tar.zst
nixlib-c4ba2e3ef691c349bcce2b1e8b76a0bcd253544c.zip
cc-wrapper: Remove `stdenv.is*` for `targetPlatform.is*`
Modify bootstrapping stdenvs to make sure `targetPlatform` also passed.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix2
-rw-r--r--pkgs/stdenv/freebsd/default.nix1
-rw-r--r--pkgs/stdenv/linux/default.nix2
-rw-r--r--pkgs/stdenv/native/default.nix1
-rw-r--r--pkgs/stdenv/nix/default.nix1
5 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index fba5afd4f6ec..1592426b6e39 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -73,6 +73,7 @@ in rec {
           nativeTools  = true;
           nativePrefix = bootstrapTools;
           nativeLibc   = false;
+          targetPlatform = localSystem;
           libc         = last.pkgs.darwin.Libsystem;
           isClang      = true;
           cc           = { name = "clang-9.9.9"; outPath = bootstrapTools; };
@@ -295,6 +296,7 @@ in rec {
       inherit shell;
       nativeTools = false;
       nativeLibc  = false;
+      targetPlatform = localSystem;
       inherit (pkgs) coreutils binutils gnugrep;
       inherit (pkgs.darwin) dyld;
       cc   = pkgs.llvmPackages.clang-unwrapped;
diff --git a/pkgs/stdenv/freebsd/default.nix b/pkgs/stdenv/freebsd/default.nix
index 474a467e90c3..20be86e5f963 100644
--- a/pkgs/stdenv/freebsd/default.nix
+++ b/pkgs/stdenv/freebsd/default.nix
@@ -77,6 +77,7 @@ let inherit (localSystem) system; in
         nativeTools  = true;
         nativePrefix = "/usr";
         nativeLibc   = true;
+        targetPlatform = localSystem;
         inherit (prevStage) stdenv;
         cc           = {
           name    = "clang-9.9.9";
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index b3399cc29b34..b23d1cd01737 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -76,6 +76,7 @@ let
              else lib.makeOverridable (import ../../build-support/cc-wrapper) {
           nativeTools = false;
           nativeLibc = false;
+          targetPlatform = localSystem;
           cc = prevStage.gcc-unwrapped;
           isGNU = true;
           libc = prevStage.glibc;
@@ -239,6 +240,7 @@ in
         nativeTools = false;
         nativeLibc = false;
         isGNU = true;
+        targetPlatform = localSystem;
         cc = prevStage.gcc-unwrapped;
         libc = self.glibc;
         inherit (self) stdenv binutils coreutils gnugrep;
diff --git a/pkgs/stdenv/native/default.nix b/pkgs/stdenv/native/default.nix
index 77c868a02f88..3bcd0687bc6e 100644
--- a/pkgs/stdenv/native/default.nix
+++ b/pkgs/stdenv/native/default.nix
@@ -125,6 +125,7 @@ in
         "i686-solaris" = "/usr/gnu";
         "x86_64-solaris" = "/opt/local/gcc47";
       }.${system} or "/usr";
+      targetPlatform = localSystem;
       inherit stdenv;
     };
 
diff --git a/pkgs/stdenv/nix/default.nix b/pkgs/stdenv/nix/default.nix
index ef088ecbf644..2363fb966e7a 100644
--- a/pkgs/stdenv/nix/default.nix
+++ b/pkgs/stdenv/nix/default.nix
@@ -30,6 +30,7 @@ bootStages ++ [
         nativeTools = false;
         nativePrefix = stdenv.lib.optionalString hostPlatform.isSunOS "/usr";
         nativeLibc = true;
+        targetPlatform = localSystem;
         inherit stdenv;
         inherit (prevStage) binutils coreutils gnugrep;
         cc = prevStage.gcc.cc;