about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2020-03-23 00:25:34 -0400
committerMatthew Bauer <mjbauer95@gmail.com>2020-03-23 00:32:45 -0400
commitb0b0a06788d5a7b3a3b35063b058f1326f10e983 (patch)
treed1e760276967c85649a46edadfe97c9b0efd0b14 /pkgs/stdenv
parentb0c75e811a6ad20f2f23f6392eae06a4d854c4dd (diff)
downloadnixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.tar
nixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.tar.gz
nixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.tar.bz2
nixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.tar.lz
nixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.tar.xz
nixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.tar.zst
nixlib-b0b0a06788d5a7b3a3b35063b058f1326f10e983.zip
bintools: only add macos flags when targeting macOS
We can’t set this for cross-compiling since we use the GNU linker.
Instead, set these flags only when targetPlatform is macOS.

Fixes #80754

Fixes #83141
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix2
1 files changed, 0 insertions, 2 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index ef1ebfc32c1b..2d5a191fc32b 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -36,9 +36,7 @@ in rec {
     export NIX_IGNORE_LD_THROUGH_GCC=1
     export SDKROOT=
 
-    # Ensure consistent LC_VERSION_MIN_MACOSX and remove LC_UUID.
     export MACOSX_DEPLOYMENT_TARGET=${macosVersionMin}
-    export NIX_LDFLAGS+=" -macosx_version_min ${macosVersionMin} -sdk_version ${appleSdkVersion} -no_uuid"
 
     # Workaround for https://openradar.appspot.com/22671534 on 10.11.
     export gl_cv_func_getcwd_abort_bug=no