about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorroot <root@raspberrypi.(none)>2012-12-07 15:13:39 +0000
committerLluĂ­s Batlle i Rossell <viric@viric.name>2012-12-26 21:59:58 +0000
commita30086c8d520cf9e0725a7dea74895f92c152078 (patch)
tree28d3bbd9346bbfc91502b0a772eacec7ca303f6a /pkgs/stdenv
parent1b29d29c7610402cb278130f12b27900bb5a99f0 (diff)
downloadnixlib-a30086c8d520cf9e0725a7dea74895f92c152078.tar
nixlib-a30086c8d520cf9e0725a7dea74895f92c152078.tar.gz
nixlib-a30086c8d520cf9e0725a7dea74895f92c152078.tar.bz2
nixlib-a30086c8d520cf9e0725a7dea74895f92c152078.tar.lz
nixlib-a30086c8d520cf9e0725a7dea74895f92c152078.tar.xz
nixlib-a30086c8d520cf9e0725a7dea74895f92c152078.tar.zst
nixlib-a30086c8d520cf9e0725a7dea74895f92c152078.zip
Disabling ppl and cloog on gcc for raspberrypi. Shorter stdenv builds.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 6a202951c7c1..d8b404cc7761 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -239,7 +239,8 @@ rec {
       inherit (stdenvLinuxBoot3Pkgs) binutils;
       coreutils = bootstrapTools;
       libc = stdenvLinuxGlibc;
-      gcc = stdenvLinuxBoot3Pkgs.gcc.gcc;
+      gcc = stdenvLinuxBoot3Pkgs.gcc.gcc.override (if platform.name == "raspberrypi" then
+	{ ppl = null; cloog = null; } else {});
       name = "";
     };
     extraPath = [ stdenvLinuxBoot3Pkgs.xz ];
@@ -278,7 +279,7 @@ rec {
       inherit (stdenvLinuxBoot3Pkgs) binutils;
       inherit (stdenvLinuxBoot4Pkgs) coreutils;
       libc = stdenvLinuxGlibc;
-      gcc = stdenvLinuxBoot3Pkgs.gcc.gcc;
+      gcc = stdenvLinuxBoot4.gcc.gcc;
       shell = stdenvLinuxBoot4Pkgs.bash + "/bin/bash";
       name = "";
     };