about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authortoonn <toonn@toonn.io>2023-11-12 05:52:30 -0800
committertoonn <toonn@toonn.io>2023-11-12 15:08:11 +0100
commit887d33a089c556592b789a7699019babf8aa2402 (patch)
tree9004cec2395ecab47b34a0d64e2add08d0ad8cb7 /pkgs/stdenv
parent44cf4801c0937b76cc6f416a0b160b5d1b3286af (diff)
downloadnixlib-887d33a089c556592b789a7699019babf8aa2402.tar
nixlib-887d33a089c556592b789a7699019babf8aa2402.tar.gz
nixlib-887d33a089c556592b789a7699019babf8aa2402.tar.bz2
nixlib-887d33a089c556592b789a7699019babf8aa2402.tar.lz
nixlib-887d33a089c556592b789a7699019babf8aa2402.tar.xz
nixlib-887d33a089c556592b789a7699019babf8aa2402.tar.zst
nixlib-887d33a089c556592b789a7699019babf8aa2402.zip
freshBootstrapTools: Overlay the package set with the desired LLVM
As reported in #241692, since the `llvmPackages` bump the
bootstrap-tools started failing to build due to a mismatch in LLVM
versions used to build certain tools.

By overlaying the imported package set to specify `llvmPackages`, we get
everything built with the expected LLVM version.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/make-bootstrap-tools.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/stdenv/darwin/make-bootstrap-tools.nix b/pkgs/stdenv/darwin/make-bootstrap-tools.nix
index 448d6ecd9f17..b51b5fdb34bc 100644
--- a/pkgs/stdenv/darwin/make-bootstrap-tools.nix
+++ b/pkgs/stdenv/darwin/make-bootstrap-tools.nix
@@ -1,5 +1,8 @@
 { pkgspath ? ../../.., test-pkgspath ? pkgspath
 , localSystem ? { system = builtins.currentSystem; }
+# Specify the desired LLVM version in an overlay to avoid the use of
+# mismatching versions.
+, overlays ? [(self: super: { llvmPackages = super.llvmPackages_11; })]
 , crossSystem ? null
 , bootstrapFiles ? null
 }:
@@ -13,11 +16,9 @@ let cross = if crossSystem != null
               in (import "${pkgspath}/pkgs/stdenv/darwin" args');
            }
       else {};
-in with import pkgspath ({ inherit localSystem; } // cross // custom-bootstrap);
+in with import pkgspath ({ inherit localSystem overlays; } // cross // custom-bootstrap);
 
-let
-  llvmPackages = llvmPackages_11;
-in rec {
+rec {
   coreutils_ = coreutils.override (args: {
     # We want coreutils without ACL support.
     aclSupport = false;