about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2011-12-12 14:02:12 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2011-12-12 14:02:12 +0000
commit3ea1c308466d2daad18ceac4ef8176bb1c3c85de (patch)
tree8f3478442e51a6edc6f0c4d4b7cae18640422ac2 /pkgs/stdenv
parentef7b97badef4e6b26b060ed7ff5fba6d0c269942 (diff)
downloadnixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.tar
nixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.tar.gz
nixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.tar.bz2
nixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.tar.lz
nixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.tar.xz
nixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.tar.zst
nixlib-3ea1c308466d2daad18ceac4ef8176bb1c3c85de.zip
* Remove the NIX_STRIP_DEBUG flag. It was undocumented and confusing
  in its interaction with the ‘dontStrip’ attribute.

svn path=/nixpkgs/branches/stdenv-updates/; revision=30848
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/docs.txt93
-rw-r--r--pkgs/stdenv/generic/setup.sh7
-rw-r--r--pkgs/stdenv/linux/default.nix4
-rwxr-xr-xpkgs/stdenv/mingw/setup.sh7
-rw-r--r--pkgs/stdenv/native/default.nix1
-rw-r--r--pkgs/stdenv/nix/prehook.sh1
6 files changed, 3 insertions, 110 deletions
diff --git a/pkgs/stdenv/generic/docs.txt b/pkgs/stdenv/generic/docs.txt
deleted file mode 100644
index 060f3cd154b9..000000000000
--- a/pkgs/stdenv/generic/docs.txt
+++ /dev/null
@@ -1,93 +0,0 @@
-* genericBuild performs a generic build of (typically) autotool-style
-  packages
-
-  
-* unpack phase
-
-** may be overriden by setting $unpackPhase to point at a function that
-   unpacks the source (which should set $sourceRoot)
-
-** the generic unpacker unpacks all sources specified by $srcs, or
-   $src if $srcs is empty
-
-** supports tar, bzipped tar, gzipped tar, compressed tar, zip
-
-** zip must be in scope (in $buildinputs)
-
-** additional file types may be supported by setting $findUnpacker,
-   which is called with a single argument specifying the file to be
-   unpacked
-
-** $findUnpacker should set $unpackCmd, specifying the full command to
-   unpack the file (must include the file name)
-
-** alternatively, $unpackCmd can be set before calling the generic
-   builder (e.g., 'unpackCmd="unrar x $src"'); this only works if
-   there is a single source file
-
-** the generic unpacker then sets $sourceRoot to the name of the
-   directory created by unpacking the source archives
-
-** the source archives should produce only one directory
-
-** alternatively, $setSourceRoot may be set to a function that sets
-   $sourceRoot
-
-
-* the generic builder then chdirs to $sourceRoot
-
-
-* patch phase (skipped if neither $patchPhase nor $patches are set)
-
-** may be overriden by setting $patchPhase to point at a function that
-   unpacks the source (which should set $sourceRoot)
-
-** if the $patches variable is set, it runs `patch -p1 < ...' in
-   $sourceRoot for each element in $patches (the `patch' command
-   should be in $PATH; note that it isn't in the standard environment)
-
-
-* configuration phase
-
-** may be overriden by setting $configurePhase to point at a function
-
-** calls $preConfigurer first, if set (useful for running
-   autoconf/automake)
-
-** the configure script is specified by $configureScript, which
-   defaults to ./configure
-   
-** if no executable file exists at $configureScript, does nothing
-
-** if a file ./ltmain.sh exists and $dontFixLibtool is not set, calls
-   function fixLibtool to remove its default search path (/usr etc.)
-
-** adds "--prefix=$out" to $configureFlags unless $dontAddPrefix is
-   set
-
-** calls $configureScript with $configureFlags
-
-** calls $postConfigurer, if set (useful for any last-minute patches
-   prior to building)
-
-
-* build phase
-
-** may be overriden by setting $buildPhase to point at a function
-
-** runs make with flags $makeFlags
-
-
-* install phase
-
-** may be overriden by setting $installPhase to point at a function
-
-** runs make with flags $installFlags
-
-** unless $dontStrip is set or $NIX_STRIP_DEBUG is not 1, finds all *.a
-   files in $out and runs "strip -S" on them (executables and dynamic
-   libraries can be stripped automatically by setting NIX_STRIP_DEBUG
-   to 1 (default))
-
-** if $propagatedBuildInputs is set, its contents are written to
-   $out/nix-support/propagated-build-inputs
diff --git a/pkgs/stdenv/generic/setup.sh b/pkgs/stdenv/generic/setup.sh
index bf1642d84aa7..623273962393 100644
--- a/pkgs/stdenv/generic/setup.sh
+++ b/pkgs/stdenv/generic/setup.sh
@@ -237,13 +237,6 @@ if test "$NIX_NO_SELF_RPATH" != "1"; then
 fi
 
 
-# Strip debug information by default.
-if test -z "$NIX_STRIP_DEBUG"; then
-    export NIX_STRIP_DEBUG=1
-    export NIX_CFLAGS_STRIP="-g0 -Wl,--strip-debug"
-fi
-
-
 # Set the TZ (timezone) environment variable, otherwise commands like
 # `date' will complain (e.g., `Tue Mar 9 10:01:47 Local time zone must
 # be set--see zic manual page 2004').
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index a45e6a718170..5385fb75e214 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -5,7 +5,9 @@
 # ensuring purity of components produced by it.
 
 # The function defaults are for easy testing.
-{system ? "i686-linux", allPackages ? import ../../top-level/all-packages.nix, platform}:
+{ system ? "i686-linux"
+, allPackages ? import ../../top-level/all-packages.nix
+, platform ? null }:
 
 rec {
 
diff --git a/pkgs/stdenv/mingw/setup.sh b/pkgs/stdenv/mingw/setup.sh
index 058d8cb18918..2bc961dfaed6 100755
--- a/pkgs/stdenv/mingw/setup.sh
+++ b/pkgs/stdenv/mingw/setup.sh
@@ -202,13 +202,6 @@ if test "$NIX_NO_SELF_RPATH" != "1"; then
 fi
 
 
-# Strip debug information by default.
-if test -z "$NIX_STRIP_DEBUG"; then
-    export NIX_STRIP_DEBUG=1
-    export NIX_CFLAGS_STRIP="-g0 -Wl,--strip-debug"
-fi
-
-
 # Set the TZ (timezone) environment variable, otherwise commands like
 # `date' will complain (e.g., `Tue Mar 9 10:01:47 Local time zone must
 # be set--see zic manual page 2004').
diff --git a/pkgs/stdenv/native/default.nix b/pkgs/stdenv/native/default.nix
index 1f2117ebba0f..6cb45909019d 100644
--- a/pkgs/stdenv/native/default.nix
+++ b/pkgs/stdenv/native/default.nix
@@ -19,7 +19,6 @@ rec {
     export NIX_DONT_SET_RPATH=1
     export NIX_NO_SELF_RPATH=1
     dontFixLibtool=1
-    NIX_STRIP_DEBUG=0
     stripAllFlags=" " # the Darwin "strip" command doesn't know "-s" 
   '';
 
diff --git a/pkgs/stdenv/nix/prehook.sh b/pkgs/stdenv/nix/prehook.sh
index 55389b7d7716..ea80355f6bb1 100644
--- a/pkgs/stdenv/nix/prehook.sh
+++ b/pkgs/stdenv/nix/prehook.sh
@@ -5,7 +5,6 @@ if test "$system" = "i686-darwin" -o "$system" = "powerpc-darwin" -o "$system" =
     export NIX_DONT_SET_RPATH=1
     export NIX_NO_SELF_RPATH=1
     dontFixLibtool=1
-    NIX_STRIP_DEBUG=0 # !!! do we still need this?
     stripAllFlags=" " # the Darwin "strip" command doesn't know "-s" 
     xargsFlags=" "
 fi