about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-11-04 11:33:17 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-11-04 11:33:17 +0100
commit322f87137c018813a9f3d6d9fbdfb208c430f154 (patch)
treea750173b9a89443b0aedaaa6c0f988d58041c0cf /pkgs/stdenv
parent5b744f4cd9aca7097edbabdc8f974c45cba7fe26 (diff)
parent179b8146e668636fe59ef7663a6c8cd15d00db7e (diff)
downloadnixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.tar
nixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.tar.gz
nixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.tar.bz2
nixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.tar.lz
nixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.tar.xz
nixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.tar.zst
nixlib-322f87137c018813a9f3d6d9fbdfb208c430f154.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/make-derivation.nix13
1 files changed, 1 insertions, 12 deletions
diff --git a/pkgs/stdenv/generic/make-derivation.nix b/pkgs/stdenv/generic/make-derivation.nix
index 9926a13190f6..08a914787c35 100644
--- a/pkgs/stdenv/generic/make-derivation.nix
+++ b/pkgs/stdenv/generic/make-derivation.nix
@@ -12,9 +12,7 @@ rec {
   # * https://nixos.org/nix/manual/#ssec-derivation
   #   Explanation about derivations in general
   mkDerivation =
-    { name ? if attrs ? pname && attrs ? version
-        then "${attrs.pname}-${attrs.version}"
-        else ""
+    { name ? ""
 
     # These types of dependencies are all exhaustively documented in
     # the "Specifying Dependencies" section of the "Standard
@@ -67,8 +65,6 @@ rec {
     , pos ? # position used in error messages and for meta.position
         (if attrs.meta.description or null != null
           then builtins.unsafeGetAttrPos "description" attrs.meta
-          else if attrs.version or null != null
-          then builtins.unsafeGetAttrPos "version" attrs
           else builtins.unsafeGetAttrPos "name" attrs)
     , separateDebugInfo ? false
     , outputs ? [ "out" ]
@@ -82,13 +78,6 @@ rec {
 
     , ... } @ attrs:
 
-    # Check that the name is consistent with pname and version:
-    assert lib.assertMsg
-      (lib.lists.all (name: builtins.hasAttr name attrs) ["name" "pname" "version"]
-        -> lib.strings.hasSuffix "${attrs.pname}-${attrs.version}" attrs.name)
-      ("mkDerivation: `name` (\"${attrs.name}\") must be consistent " +
-       "with `pname-version` \"${attrs.pname}-${attrs.version}\"");
-
     let
       # TODO(@oxij, @Ericson2314): This is here to keep the old semantics, remove when
       # no package has `doCheck = true`.