about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2021-01-22 14:07:06 -0800
committerJonathan Ringer <jonringer117@gmail.com>2021-01-22 14:07:06 -0800
commit0bc275e63423456d6deb650e146120c39c1e0723 (patch)
tree1d33aa707b24fa58952162457e243c731836f99b /pkgs/stdenv
parent2e5475381b65290e08d357fa1434bd28d0c21cfa (diff)
downloadnixlib-0bc275e63423456d6deb650e146120c39c1e0723.tar
nixlib-0bc275e63423456d6deb650e146120c39c1e0723.tar.gz
nixlib-0bc275e63423456d6deb650e146120c39c1e0723.tar.bz2
nixlib-0bc275e63423456d6deb650e146120c39c1e0723.tar.lz
nixlib-0bc275e63423456d6deb650e146120c39c1e0723.tar.xz
nixlib-0bc275e63423456d6deb650e146120c39c1e0723.tar.zst
nixlib-0bc275e63423456d6deb650e146120c39c1e0723.zip
Revert "lib: Clean up how linux and gcc config is specified"
This is a stdenv-rebuild, and should not be merged
into master

This reverts commit 8929989614589ee3acd070a6409b2b9700c92d65.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/make-derivation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/stdenv/generic/make-derivation.nix b/pkgs/stdenv/generic/make-derivation.nix
index e8ccd02c041c..0eb799e45258 100644
--- a/pkgs/stdenv/generic/make-derivation.nix
+++ b/pkgs/stdenv/generic/make-derivation.nix
@@ -279,7 +279,7 @@ in rec {
         } // lib.optionalAttrs (hardeningDisable != [] || hardeningEnable != []) {
           NIX_HARDENING_ENABLE = enabledHardeningOptions;
         } // lib.optionalAttrs (stdenv.hostPlatform.isx86_64 && stdenv.hostPlatform ? platform.gcc.arch) {
-          requiredSystemFeatures = attrs.requiredSystemFeatures or [] ++ [ "gccarch-${stdenv.hostPlatform.gcc.arch}" ];
+          requiredSystemFeatures = attrs.requiredSystemFeatures or [] ++ [ "gccarch-${stdenv.hostPlatform.platform.gcc.arch}" ];
         } // lib.optionalAttrs (stdenv.buildPlatform.isDarwin) {
           inherit __darwinAllowLocalNetworking;
           # TODO: remove lib.unique once nix has a list canonicalization primitive