about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2024-03-17 19:28:47 +0100
committerRobert Hensing <robert@roberthensing.nl>2024-03-17 19:28:47 +0100
commit05f4b7b46d64f2f0b40cf0783a356e2efb47970a (patch)
tree9ea24238466e400beab5459099d27e8d7f498899 /pkgs/stdenv
parent8437d13b56894a4aac02fa9e2217b2ea01165bdb (diff)
downloadnixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.tar
nixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.tar.gz
nixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.tar.bz2
nixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.tar.lz
nixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.tar.xz
nixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.tar.zst
nixlib-05f4b7b46d64f2f0b40cf0783a356e2efb47970a.zip
make-derivation.nix: Fix checkMetaRecursively
Oddly, I can't reproduce the error, but this change will make it
more robust.
See https://github.com/NixOS/nixpkgs/pull/295378#issuecomment-2002094487
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/make-derivation.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/stdenv/generic/make-derivation.nix b/pkgs/stdenv/generic/make-derivation.nix
index c40eaee5e4d6..08cded664254 100644
--- a/pkgs/stdenv/generic/make-derivation.nix
+++ b/pkgs/stdenv/generic/make-derivation.nix
@@ -556,8 +556,8 @@ let
 
   meta = checkMeta.commonMeta {
     inherit validity attrs pos;
-    references = attrs.nativeBuildInputs ++ attrs.buildInputs
-              ++ attrs.propagatedNativeBuildInputs ++ attrs.propagatedBuildInputs;
+    references = attrs.nativeBuildInputs or [] ++ attrs.buildInputs or []
+              ++ attrs.propagatedNativeBuildInputs or [] ++ attrs.propagatedBuildInputs or [];
   };
   validity = checkMeta.assertValidity { inherit meta attrs; };