about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-03-02 20:06:09 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2019-04-26 21:54:49 -0400
commit037f62bbadb96c3587054613a9f107e34f6011c9 (patch)
tree7b2780f46a79356f6da78d730271f51c2edba00f /pkgs/stdenv
parentec7d72a57d5ba18a35451b174e2f3c8d4a425b94 (diff)
downloadnixlib-037f62bbadb96c3587054613a9f107e34f6011c9.tar
nixlib-037f62bbadb96c3587054613a9f107e34f6011c9.tar.gz
nixlib-037f62bbadb96c3587054613a9f107e34f6011c9.tar.bz2
nixlib-037f62bbadb96c3587054613a9f107e34f6011c9.tar.lz
nixlib-037f62bbadb96c3587054613a9f107e34f6011c9.tar.xz
nixlib-037f62bbadb96c3587054613a9f107e34f6011c9.tar.zst
nixlib-037f62bbadb96c3587054613a9f107e34f6011c9.zip
stdenv/darwin: put bash in extraBuildInputs
patch-shebangs should pick these up as they are runtime dependencies.
This avoids bootstrap-tools leaking into the outputs.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 3102b255c0a6..2fc9c8ceb04a 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -280,8 +280,8 @@ in rec {
     # enables patchShebangs above. Unfortunately, patchShebangs ignores our $SHELL setting
     # and instead goes by $PATH, which happens to contain bootstrapTools. So it goes and
     # patches our shebangs back to point at bootstrapTools. This makes sure bash comes first.
-    extraNativeBuildInputs = with pkgs; [ xz pkgs.bash ];
-    extraBuildInputs = [ pkgs.darwin.CF ];
+    extraNativeBuildInputs = with pkgs; [ xz ];
+    extraBuildInputs = [ pkgs.darwin.CF pkgs.bash ];
     libcxx = pkgs.libcxx;
 
     extraPreHook = ''
@@ -338,8 +338,8 @@ in rec {
     };
   in with prevStage; stageFun 4 prevStage {
     shell = "${pkgs.bash}/bin/bash";
-    extraNativeBuildInputs = with pkgs; [ xz pkgs.bash ];
-    extraBuildInputs = [ pkgs.darwin.CF ];
+    extraNativeBuildInputs = with pkgs; [ xz ];
+    extraBuildInputs = [ pkgs.darwin.CF pkgs.bash ];
     libcxx = pkgs.libcxx;
 
     extraPreHook = ''