about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorAndreas Wiese <aw-nixos@meterriblecrew.net>2020-04-07 00:50:36 +0200
committerAndreas Wiese <aw-nixos@meterriblecrew.net>2020-04-07 01:00:58 +0200
commitf4e273dbacce77d6ab9c1cd0beb6f6d7580ae663 (patch)
tree3783454132f9abd29085e6a7918a1e5665e6a3de /pkgs/shells
parent41fa7a229551e39bce021f9c9f12c3ed2dd25950 (diff)
downloadnixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.tar
nixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.tar.gz
nixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.tar.bz2
nixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.tar.lz
nixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.tar.xz
nixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.tar.zst
nixlib-f4e273dbacce77d6ab9c1cd0beb6f6d7580ae663.zip
zsh-nix-shell: init at (unstable-)2019-12-20
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/zsh-nix-shell/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/shells/zsh/zsh-nix-shell/default.nix b/pkgs/shells/zsh/zsh-nix-shell/default.nix
new file mode 100644
index 000000000000..c424cc334836
--- /dev/null
+++ b/pkgs/shells/zsh/zsh-nix-shell/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchFromGitHub, pkgs }:
+
+# To make use of this derivation, use
+# `programs.zsh.interactiveShellInit = "source ${pkgs.zsh-nix-shell}/share/zsh-nix-shell/nix-shell.plugin.zsh";`
+
+stdenv.mkDerivation rec {
+  pname = "zsh-nix-shell-unstable";
+  version = "2019-12-20";
+
+  src = fetchFromGitHub {
+    owner = "chisui";
+    repo = "zsh-nix-shell";
+    rev = "a65382a353eaee5a98f068c330947c032a1263bb";
+    sha256 = "0l41ac5b7p8yyjvpfp438kw7zl9dblrpd7icjg1v3ig3xy87zv0n";
+  };
+
+  installPhase = ''
+    install -D nix-shell.plugin.zsh --target-directory=$out/share/zsh-nix-shell
+    install -D scripts/* --target-directory=$out/share/zsh-nix-shell/scripts
+  '';
+
+  meta = with stdenv.lib; {
+    description = "zsh plugin that lets you use zsh in nix-shell shell";
+    homepage = src.meta.homepage;
+    license = licenses.bsd3;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ aw ];
+  };
+}