about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorAumy <46275902+AumyF@users.noreply.github.com>2021-07-18 00:36:31 +0900
committerAumy <46275902+AumyF@users.noreply.github.com>2021-07-18 00:36:31 +0900
commitefc838b196c7bc7222d2a1046827947638f28d72 (patch)
tree00fd286664dc731c49355910b28e598b5888668f /pkgs/shells
parentab9a0ee8646b5df4d4e8fa17255ed01c96a34da4 (diff)
downloadnixlib-efc838b196c7bc7222d2a1046827947638f28d72.tar
nixlib-efc838b196c7bc7222d2a1046827947638f28d72.tar.gz
nixlib-efc838b196c7bc7222d2a1046827947638f28d72.tar.bz2
nixlib-efc838b196c7bc7222d2a1046827947638f28d72.tar.lz
nixlib-efc838b196c7bc7222d2a1046827947638f28d72.tar.xz
nixlib-efc838b196c7bc7222d2a1046827947638f28d72.tar.zst
nixlib-efc838b196c7bc7222d2a1046827947638f28d72.zip
nushell: use --features=extra by default
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/nushell/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/shells/nushell/default.nix b/pkgs/shells/nushell/default.nix
index 65ed6d5000c2..b7fa5453d87a 100644
--- a/pkgs/shells/nushell/default.nix
+++ b/pkgs/shells/nushell/default.nix
@@ -12,7 +12,7 @@
 , Security
 , nghttp2
 , libgit2
-, withStableFeatures ? true
+, withExtraFeatures ? true
 }:
 
 rustPlatform.buildRustPackage rec {
@@ -29,14 +29,14 @@ rustPlatform.buildRustPackage rec {
   cargoSha256 = "sha256-Ly59mdUzSI2pIPbckWn1WBz/o2zVzpAzaCDROLdjG7Y=";
 
   nativeBuildInputs = [ pkg-config ]
-    ++ lib.optionals (withStableFeatures && stdenv.isLinux) [ python3 ];
+    ++ lib.optionals (withExtraFeatures && stdenv.isLinux) [ python3 ];
 
   buildInputs = [ openssl ]
     ++ lib.optionals stdenv.isDarwin [ zlib libiconv Security ]
-    ++ lib.optionals (withStableFeatures && stdenv.isLinux) [ xorg.libX11 ]
-    ++ lib.optionals (withStableFeatures && stdenv.isDarwin) [ AppKit nghttp2 libgit2 ];
+    ++ lib.optionals (withExtraFeatures && stdenv.isLinux) [ xorg.libX11 ]
+    ++ lib.optionals (withExtraFeatures && stdenv.isDarwin) [ AppKit nghttp2 libgit2 ];
 
-  cargoBuildFlags = lib.optional withStableFeatures "--features stable";
+  cargoBuildFlags = lib.optional withExtraFeatures "--features=extra";
 
   # TODO investigate why tests are broken on darwin
   # failures show that tests try to write to paths