about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-01-03 03:22:50 +0300
committerNikolay Amiantov <ab@fmap.me>2016-01-03 03:22:50 +0300
commite312276b012c2beb93a21890933d32ed1a31c791 (patch)
tree8d9650ae6c88d0a7a282757e0132c16eea7af3d8 /pkgs/shells
parent91fbdd3ee2aa9aed769520fefc8c5a2b8a1db60a (diff)
parente60c4995fdea8ab86115149f89fca84275480fb7 (diff)
downloadnixlib-e312276b012c2beb93a21890933d32ed1a31c791.tar
nixlib-e312276b012c2beb93a21890933d32ed1a31c791.tar.gz
nixlib-e312276b012c2beb93a21890933d32ed1a31c791.tar.bz2
nixlib-e312276b012c2beb93a21890933d32ed1a31c791.tar.lz
nixlib-e312276b012c2beb93a21890933d32ed1a31c791.tar.xz
nixlib-e312276b012c2beb93a21890933d32ed1a31c791.tar.zst
nixlib-e312276b012c2beb93a21890933d32ed1a31c791.zip
Merge pull request #12000 from nathan7/nix-auto-run
command-not-found: add NIX_AUTO_RUN option, to automatically invoke nix-shell
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/fish/command-not-found.patch13
-rw-r--r--pkgs/shells/fish/default.nix2
2 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/shells/fish/command-not-found.patch b/pkgs/shells/fish/command-not-found.patch
new file mode 100644
index 000000000000..aaca001dcb67
--- /dev/null
+++ b/pkgs/shells/fish/command-not-found.patch
@@ -0,0 +1,13 @@
+diff --git a/share/functions/__fish_config_interactive.fish b/share/functions/__fish_config_interactive.fish
+index c3864a8..a12ac4d 100644
+--- a/share/functions/__fish_config_interactive.fish
++++ b/share/functions/__fish_config_interactive.fish
+@@ -230,7 +230,7 @@ function __fish_config_interactive -d "Initializations that should be performed
+ 		# Check for NixOS handler
+ 		else if test -f /run/current-system/sw/bin/command-not-found
+ 			function __fish_command_not_found_handler --on-event fish_command_not_found
+-				/run/current-system/sw/bin/command-not-found $argv[1]
++				/run/current-system/sw/bin/command-not-found $argv
+ 			end
+ 		# Ubuntu Feisty places this command in the regular path instead
+ 		else if type -q -p command-not-found
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index ef3794d5144c..c2fcfa3e7c18 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -4,6 +4,8 @@ stdenv.mkDerivation rec {
   name = "fish-${version}";
   version = "2.2.0";
 
+  patches = [ ./command-not-found.patch ];
+
   src = fetchurl {
     url = "http://fishshell.com/files/${version}/${name}.tar.gz";
     sha256 = "0ympqz7llmf0hafxwglykplw6j5cz82yhlrw50lw4bnf2kykjqx7";