about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2020-05-07 15:55:58 +0100
committerGitHub <noreply@github.com>2020-05-07 15:55:58 +0100
commitaf8d490694d43bb2871ec7a85df97bb05de98978 (patch)
treead06c2bc019c84dad9b3f09ef3c5a1e5b42624b8 /pkgs/shells
parent68b25d3b9df6c0901595ef891aadbb57279ecb4d (diff)
parenta85b07cbcb7a034bc07dda3642bc68fe621a63ec (diff)
downloadnixlib-af8d490694d43bb2871ec7a85df97bb05de98978.tar
nixlib-af8d490694d43bb2871ec7a85df97bb05de98978.tar.gz
nixlib-af8d490694d43bb2871ec7a85df97bb05de98978.tar.bz2
nixlib-af8d490694d43bb2871ec7a85df97bb05de98978.tar.lz
nixlib-af8d490694d43bb2871ec7a85df97bb05de98978.tar.xz
nixlib-af8d490694d43bb2871ec7a85df97bb05de98978.tar.zst
nixlib-af8d490694d43bb2871ec7a85df97bb05de98978.zip
Merge pull request #87189 from andir/bashcompletions
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash/bash-completion/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/shells/bash/bash-completion/default.nix b/pkgs/shells/bash/bash-completion/default.nix
index 8463b1750d16..e5ef70e43a99 100644
--- a/pkgs/shells/bash/bash-completion/default.nix
+++ b/pkgs/shells/bash/bash-completion/default.nix
@@ -30,6 +30,10 @@ stdenv.mkDerivation rec {
     python3Packages.pexpect
     python3Packages.pytest
     bashInteractive
+
+    # use xdist to speed up the test run, just like upstream:
+    # https://github.com/scop/bash-completion/blob/009bf2228c68894629eb6fd17b3dc0f1f6d67615/test/requirements.txt#L4
+    python3Packages.pytest_xdist
   ];
 
   # - ignore test_gcc on ARM because it assumes -march=native
@@ -40,7 +44,7 @@ stdenv.mkDerivation rec {
   # - ignore test_ls because impure logic
   # - ignore test_screen because it assumes vt terminals exist
   checkPhase = ''
-    pytest . \
+    pytest -n $NIX_BUILD_CORES . \
       ${stdenv.lib.optionalString (stdenv.hostPlatform.isAarch64 || stdenv.hostPlatform.isAarch32) "--ignore=test/t/test_gcc.py"} \
       --ignore=test/t/test_chsh.py \
       --ignore=test/t/test_ether_wake.py \