about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorMartin Weinelt <hexa@darmstadt.ccc.de>2020-11-23 15:42:27 +0100
committerJonathan Ringer <jonringer@users.noreply.github.com>2020-11-23 11:57:29 -0800
commit9ac42658f96d5561f8c6f50ab06e7b43f9bf5196 (patch)
treeade9ffef6c6e1b4ed1c2619fd7d083929f68e1cd /pkgs/shells
parent97597f09c0a60ef25849ff4e0d1feb85cd2a6daa (diff)
downloadnixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.tar
nixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.tar.gz
nixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.tar.bz2
nixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.tar.lz
nixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.tar.xz
nixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.tar.zst
nixlib-9ac42658f96d5561f8c6f50ab06e7b43f9bf5196.zip
dash: add patch to prevent code execution when noexec is set
Dashs noexec flag `-n` did not work as documented, which could result in
code being inadvertently executed.
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/dash/default.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/pkgs/shells/dash/default.nix b/pkgs/shells/dash/default.nix
index 030e5695b225..bc270daf09cf 100644
--- a/pkgs/shells/dash/default.nix
+++ b/pkgs/shells/dash/default.nix
@@ -1,17 +1,25 @@
 { stdenv, buildPackages, autoreconfHook, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "dash-0.5.11.2";
+  pname = "dash";
+  version = "0.5.11.2";
 
   src = fetchurl {
-    url = "http://gondor.apana.org.au/~herbert/dash/files/${name}.tar.gz";
+    url = "http://gondor.apana.org.au/~herbert/dash/files/${pname}-${version}.tar.gz";
     sha256 = "0pvdpm1cgfbc25ramn4305a0158yq031q1ain4dc972rnxl7vyq0";
   };
 
   hardeningDisable = [ "format" ];
 
   # Temporary fix until a proper one is accepted upstream
-  patches = stdenv.lib.optional stdenv.isDarwin ./0001-fix-dirent64-et-al-on-darwin.patch;
+  patches = [
+    (fetchurl {
+      # Dash executes code when noexec ("-n") is specified
+      # https://www.openwall.com/lists/oss-security/2020/11/11/3
+      url = "https://git.kernel.org/pub/scm/utils/dash/dash.git/patch/?id=29d6f2148f10213de4e904d515e792d2cf8c968e";
+      sha256 = "08q90bx36ixwlcj331dh7420qyj8i0qh1cc1gljrhd83fhl9w0y5";
+    })
+  ] ++ stdenv.lib.optional stdenv.isDarwin ./0001-fix-dirent64-et-al-on-darwin.patch;
   depsBuildBuild = [ buildPackages.stdenv.cc ];
   nativeBuildInputs = stdenv.lib.optional stdenv.isDarwin autoreconfHook;