about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorLuca Bruno <lethalman88@gmail.com>2015-11-29 16:50:26 +0100
committerLuca Bruno <lethalman88@gmail.com>2015-11-29 16:50:26 +0100
commit920b1d3591431837f4522ccff52fb65b241200cf (patch)
treea63a1acebbee20444f4b3e9e2695ec712ba7aae3 /pkgs/shells
parent07a0204282224891492e7e1cfe72830a1fc32355 (diff)
parenta9056371a0a62da46ff88183a6535635ed085dec (diff)
downloadnixlib-920b1d3591431837f4522ccff52fb65b241200cf.tar
nixlib-920b1d3591431837f4522ccff52fb65b241200cf.tar.gz
nixlib-920b1d3591431837f4522ccff52fb65b241200cf.tar.bz2
nixlib-920b1d3591431837f4522ccff52fb65b241200cf.tar.lz
nixlib-920b1d3591431837f4522ccff52fb65b241200cf.tar.xz
nixlib-920b1d3591431837f4522ccff52fb65b241200cf.tar.zst
nixlib-920b1d3591431837f4522ccff52fb65b241200cf.zip
Merge branch 'master' into closure-size
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/fish/default.nix2
-rw-r--r--pkgs/shells/pash/default.nix8
-rw-r--r--pkgs/shells/zsh/default.nix18
3 files changed, 18 insertions, 10 deletions
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 7ee4bd8707d1..c4386b1a9fb8 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -28,6 +28,8 @@ stdenv.mkDerivation rec {
     sed -e "s|gettext |${gettext}/bin/gettext |" \
         -e "s|which |${which}/bin/which |" \
         -i "$out/share/fish/functions/_.fish"
+    substituteInPlace "$out/share/fish/functions/fish_default_key_bindings.fish" \
+      --replace "clear;" "${ncurses}/bin/clear;"
   '' + stdenv.lib.optionalString (!stdenv.isDarwin) ''
     sed -i "s|Popen(\['manpath'|Popen(\['${man_db}/bin/manpath'|" "$out/share/fish/tools/create_manpage_completions.py"
   '' + ''
diff --git a/pkgs/shells/pash/default.nix b/pkgs/shells/pash/default.nix
index 63669def0ab5..b9a8397e3ba1 100644
--- a/pkgs/shells/pash/default.nix
+++ b/pkgs/shells/pash/default.nix
@@ -15,11 +15,11 @@ buildDotnetPackage rec {
 
   outputFiles = [ "Source/PashConsole/bin/Release/*" ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "An open source implementation of Windows PowerShell";
     homepage = https://github.com/Pash-Project/Pash;
-    maintainers = stdenv.lib.maintainers.fornever;
-    platforms = with stdenv.lib.platforms; all;
-    license = with stdenv.lib.licenses; [ bsd3 gpl3 ];
+    maintainers = [ maintainers.fornever ];
+    platforms = platforms.all;
+    license = with licenses; [ bsd3 gpl3 ];
   };
 }
diff --git a/pkgs/shells/zsh/default.nix b/pkgs/shells/zsh/default.nix
index 0e25bba9fe35..7b12ab7cab81 100644
--- a/pkgs/shells/zsh/default.nix
+++ b/pkgs/shells/zsh/default.nix
@@ -21,13 +21,19 @@ stdenv.mkDerivation {
 
   buildInputs = [ ncurses coreutils pcre ];
 
-  preConfigure = ''
-    configureFlags="--enable-maildir-support --enable-multibyte --enable-zprofile=$out/etc/zprofile --with-tcsetpgrp --enable-pcre"
-  '';
+  configureFlags = [
+    "--enable-maildir-support"
+    "--enable-multibyte"
+    "--enable-zprofile=$out/etc/zprofile"
+    "--with-tcsetpgrp"
+    "--enable-pcre"
+  ];
 
-  # Some tests fail on hydra, see
-  # http://hydra.nixos.org/build/25637689/nixlog/1
-  doCheck = false;
+  # the zsh/zpty module is not available on hydra
+  # so skip groups Y Z
+  checkFlagsArray = ''
+    (TESTNUM=A TESTNUM=B TESTNUM=C TESTNUM=D TESTNUM=E TESTNUM=V TESTNUM=W)
+  '';
 
   # XXX: think/discuss about this, also with respect to nixos vs nix-on-X
   postInstall = ''