about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2023-01-10 13:20:00 +0100
committerGitHub <noreply@github.com>2023-01-10 13:20:00 +0100
commit79562c9aa1f96eeebda10ca34e463cb715ebdb1a (patch)
tree3f7b00dcef33035bf8fad7c66b90306bd71e045d /pkgs/shells
parentf386617df539136500dc5826a0088bfa7eb41c74 (diff)
parent6d3d0c1ffc1d613f34b6178708c52208b493d366 (diff)
downloadnixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.tar
nixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.tar.gz
nixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.tar.bz2
nixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.tar.lz
nixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.tar.xz
nixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.tar.zst
nixlib-79562c9aa1f96eeebda10ca34e463cb715ebdb1a.zip
Merge pull request #209307 from deejayem/zsh-forgit-23.01.0
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/zsh-forgit/default.nix22
1 files changed, 15 insertions, 7 deletions
diff --git a/pkgs/shells/zsh/zsh-forgit/default.nix b/pkgs/shells/zsh/zsh-forgit/default.nix
index ce99b5e34484..ff1a5f7d9c75 100644
--- a/pkgs/shells/zsh/zsh-forgit/default.nix
+++ b/pkgs/shells/zsh/zsh-forgit/default.nix
@@ -1,14 +1,25 @@
-{ stdenv, lib, bash, fetchFromGitHub, makeWrapper, fzf, git }:
+{ stdenv
+, lib
+, bash
+, coreutils
+, findutils
+, fetchFromGitHub
+, fzf
+, git
+, gnugrep
+, gnused
+, makeWrapper
+}:
 
 stdenv.mkDerivation rec {
   pname = "zsh-forgit";
-  version = "22.12.0";
+  version = "23.01.0";
 
   src = fetchFromGitHub {
     owner = "wfxr";
     repo = "forgit";
     rev = version;
-    sha256 = "0juBNUJW4SU3Cl6ouD+xMYzlCJOL7NAYpueZ6V56/ck=";
+    sha256 = "sha256-guAjxFhtybbRyRRXDELDHrM2Xzmi96wPxD2nhL9Ifmk=";
   };
 
   strictDeps = true;
@@ -16,9 +27,6 @@ stdenv.mkDerivation rec {
   postPatch = ''
     substituteInPlace forgit.plugin.zsh \
       --replace "\$INSTALL_DIR/bin/git-forgit" "$out/bin/git-forgit"
-
-    substituteInPlace bin/git-forgit \
-      --replace "/bin/bash" "${bash}/bin/bash"
   '';
 
   dontBuild = true;
@@ -31,7 +39,7 @@ stdenv.mkDerivation rec {
     install -D bin/git-forgit $out/bin/git-forgit
     install -D forgit.plugin.zsh $out/share/zsh/${pname}/forgit.plugin.zsh
     wrapProgram $out/bin/git-forgit \
-      --prefix PATH : ${lib.makeBinPath [ fzf git ]}
+      --prefix PATH : ${lib.makeBinPath [ bash coreutils findutils fzf git gnugrep gnused ]}
 
     runHook postInstall
   '';