about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorMaxHearnden <maxoscarhearnden@gmail.com>2023-05-24 15:08:09 +0100
committerArtturin <Artturin@artturin.com>2023-06-23 14:17:23 +0300
commit77f84f07c47737d66445c5aa32a3740d1f91e0fa (patch)
tree373f5ae60eab1e982f497ce2cfc7b13c66099317 /pkgs/shells
parentf91ee3065de91a3531329a674a45ddcb3467a650 (diff)
downloadnixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.tar
nixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.tar.gz
nixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.tar.bz2
nixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.tar.lz
nixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.tar.xz
nixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.tar.zst
nixlib-77f84f07c47737d66445c5aa32a3740d1f91e0fa.zip
zsh: fix cross by using pkg-config to discover libpcre
The configure script calls pcre-config to find pcre however using
nativeBuildInputs for this meant that zsh found the native libraries.

weirdly only pkgsCross.armv7l-hf-multiplatform.zsh was failing and not
pkgsCross.aarch64-multiplatform.zsh
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/pkgs/shells/zsh/default.nix b/pkgs/shells/zsh/default.nix
index 18fa69c60427..1a085c0e062c 100644
--- a/pkgs/shells/zsh/default.nix
+++ b/pkgs/shells/zsh/default.nix
@@ -10,6 +10,7 @@
 , texinfo
 , ncurses
 , pcre
+, pkg-config
 , buildPackages }:
 
 let
@@ -32,7 +33,7 @@ stdenv.mkDerivation {
   ];
 
   strictDeps = true;
-  nativeBuildInputs = [ autoreconfHook perl groff texinfo pcre]
+  nativeBuildInputs = [ autoreconfHook perl groff texinfo pkg-config ]
                       ++ lib.optionals stdenv.isLinux [ util-linux yodl ];
 
   buildInputs = [ ncurses pcre ];
@@ -56,6 +57,11 @@ stdenv.mkDerivation {
     "zsh_cv_sys_dynamic_strip_lib=yes"
   ];
 
+  preConfigure = ''
+    # use pkg-config instead of pcre-config
+    configureFlagsArray+=("PCRECONF=''${PKG_CONFIG} libpcre")
+  '';
+
   # the zsh/zpty module is not available on hydra
   # so skip groups Y Z
   checkFlags = map (T: "TESTNUM=${T}") (lib.stringToCharacters "ABCDEVW");