about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2023-01-02 03:01:35 +0100
committerJan Tojnar <jtojnar@gmail.com>2023-01-02 03:04:32 +0100
commit5810109b422a3d578ab803280b594133b20576f2 (patch)
tree945523abae70d25e7e1c1987757d53e1bc7e8d17 /pkgs/shells
parentc791e28190627f19d9506683f296cc970ef655ee (diff)
parent3f1573f21671b737b24efeed714958cf0e5cc7f5 (diff)
downloadnixlib-5810109b422a3d578ab803280b594133b20576f2.tar
nixlib-5810109b422a3d578ab803280b594133b20576f2.tar.gz
nixlib-5810109b422a3d578ab803280b594133b20576f2.tar.bz2
nixlib-5810109b422a3d578ab803280b594133b20576f2.tar.lz
nixlib-5810109b422a3d578ab803280b594133b20576f2.tar.xz
nixlib-5810109b422a3d578ab803280b594133b20576f2.tar.zst
nixlib-5810109b422a3d578ab803280b594133b20576f2.zip
Merge branch 'staging-next' into staging
- readline6 attribute removed from all-packages.nix in d879125d61a0be8ecb2afddaca8f2b0530db0260
- readline attribute was bumped to readline82 in 50adabdd60d590c951824974356a9ccb9bb73ffc
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash/nix-bash-completions/default.nix11
-rw-r--r--pkgs/shells/zsh/spaceship-prompt/default.nix7
2 files changed, 12 insertions, 6 deletions
diff --git a/pkgs/shells/bash/nix-bash-completions/default.nix b/pkgs/shells/bash/nix-bash-completions/default.nix
index c4282ab0f646..af516a1bcaa5 100644
--- a/pkgs/shells/bash/nix-bash-completions/default.nix
+++ b/pkgs/shells/bash/nix-bash-completions/default.nix
@@ -11,8 +11,13 @@ stdenv.mkDerivation rec {
     sha256 = "1n5zs6xcnv4bv1hdaypmz7fv4j7dsr4a0ifah99iyj4p5j85i1bc";
   };
 
+  postPatch = ''
+    # Nix 2.4+ provides its own completion for the nix command, see https://github.com/hedning/nix-bash-completions/issues/20
+    substituteInPlace _nix --replace 'nix nixos-option' 'nixos-option'
+  '';
+
   strictDeps = true;
-  # To enable lazy loading via. bash-completion we need a symlink to the script
+  # To enable lazy loading via bash-completion we need a symlink to the script
   # from every command name.
   installPhase = ''
     runHook preInstall
@@ -36,8 +41,8 @@ stdenv.mkDerivation rec {
     description = "Bash completions for Nix, NixOS, and NixOps";
     license = licenses.bsd3;
     platforms = platforms.all;
-    maintainers = with maintainers; [ hedning ];
-    # Set a lower priority such that the newly provided completion from Nix 2.4 are preferred.
+    maintainers = with maintainers; [ hedning ncfavier ];
+    # Set a lower priority such that Nix wins in case of conflicts.
     priority = 10;
   };
 }
diff --git a/pkgs/shells/zsh/spaceship-prompt/default.nix b/pkgs/shells/zsh/spaceship-prompt/default.nix
index e5187658eeb9..1328020d96d4 100644
--- a/pkgs/shells/zsh/spaceship-prompt/default.nix
+++ b/pkgs/shells/zsh/spaceship-prompt/default.nix
@@ -2,13 +2,13 @@
 
 stdenvNoCC.mkDerivation rec {
   pname = "spaceship-prompt";
-  version = "3.16.7";
+  version = "4.12.0";
 
   src = fetchFromGitHub {
     owner = "denysdovhan";
     repo = pname;
     rev = "v${version}";
-    sha256 = "sha256-dMP7mDzb0xLCP2l9j4SOP47bcpuBNSoXsDecVOvZaL8=";
+    sha256 = "sha256-ZL6z5pj2xbnUZl4SK7wxiJjheUY79hwDNVYm9+biKZU=";
   };
 
   strictDeps = true;
@@ -22,6 +22,7 @@ stdenvNoCC.mkDerivation rec {
     find scripts -type f -exec install -Dm644 {} "$out/lib/spaceship-prompt/{}" \;
     find sections -type f -exec install -Dm644 {} "$out/lib/spaceship-prompt/{}" \;
     install -Dm644 spaceship.zsh "$out/lib/spaceship-prompt/spaceship.zsh"
+    install -Dm644 async.zsh "$out/lib/spaceship-prompt/async.zsh"
     install -d "$out/share/zsh/themes/"
     ln -s "$out/lib/spaceship-prompt/spaceship.zsh" "$out/share/zsh/themes/spaceship.zsh-theme"
     install -d "$out/share/zsh/site-functions/"
@@ -34,6 +35,6 @@ stdenvNoCC.mkDerivation rec {
     changelog = "https://github.com/spaceship-prompt/spaceship-prompt/releases/tag/v${version}";
     license = licenses.mit;
     platforms = platforms.unix;
-    maintainers = with maintainers; [ nyanloutre fortuneteller2k ];
+    maintainers = with maintainers; [ nyanloutre fortuneteller2k kyleondy ];
   };
 }