about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-09-29 13:06:14 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-09-29 13:06:14 +0200
commit518340624d92c7d802b23e73b078010a505b3609 (patch)
tree71f3295b1faba281e56625998540b0e697cacf90 /pkgs/shells
parent0c0c59c7cc3a1063acd60b83b66e6011ee2677bd (diff)
parent5df3ec85d8e9afd780fa80b9f96e496a61f699c1 (diff)
downloadnixlib-518340624d92c7d802b23e73b078010a505b3609.tar
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.gz
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.bz2
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.lz
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.xz
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.zst
nixlib-518340624d92c7d802b23e73b078010a505b3609.zip
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash-completion/bash-4.3.patch22
-rw-r--r--pkgs/shells/bash-completion/default.nix25
2 files changed, 9 insertions, 38 deletions
diff --git a/pkgs/shells/bash-completion/bash-4.3.patch b/pkgs/shells/bash-completion/bash-4.3.patch
deleted file mode 100644
index e893b501d311..000000000000
--- a/pkgs/shells/bash-completion/bash-4.3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-commit a9c556ccad819869a6a5d932aac0a75a99372f08
-Author: Barry Warsaw <barry@python.org>
-Date:   Wed Sep 17 19:32:43 2014 +0300
-
-    _init_completion: Handle cword < 0 (LP: #1289597)
-    
-    Previously only bash 4.3 seemed to provoke this, but now with the
-    empty command consistency tweak it occurs with earlier as well.
-
-diff --git a/bash_completion b/bash_completion
-index 7e01ae4..3bb4bc2 100644
---- a/bash_completion
-+++ b/bash_completion
-@@ -727,7 +727,7 @@ _init_completion()
-         fi
-     done
- 
--    [[ $cword -eq 0 ]] && return 1
-+    [[ $cword -le 0 ]] && return 1
-     prev=${words[cword-1]}
- 
-     [[ ${split-} ]] && _split_longopt && split=true
diff --git a/pkgs/shells/bash-completion/default.nix b/pkgs/shells/bash-completion/default.nix
index 91d6b3335416..ad4cc3d09d71 100644
--- a/pkgs/shells/bash-completion/default.nix
+++ b/pkgs/shells/bash-completion/default.nix
@@ -1,28 +1,21 @@
 { stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "bash-completion-2.1";
+  name = "bash-completion-${version}";
+  version = "2.4";
 
   src = fetchurl {
-    url = "http://bash-completion.alioth.debian.org/files/${name}.tar.bz2";
-    sha256 = "0kxf8s5bw7y50x0ksb77d3kv0dwadixhybl818w27y6mlw26hq1b";
+    url = "https://github.com/scop/bash-completion/releases/download/${version}/${name}.tar.xz";
+    sha256 = "1xlhd09sb2w3bw8qaypxgkr0782w082mcbx8zf7yzjgy0996pxy0";
   };
 
-  patches = [ ./bash-4.3.patch ];
-
   doCheck = true;
 
-  # nmcli is included in the network-manager package
-  postInstall = ''
-    rm $out/share/bash-completion/completions/nmcli
-  '';
-
-  meta = {
-    homepage = "http://bash-completion.alioth.debian.org/";
+  meta = with stdenv.lib; {
+    homepage = https://github.com/scop/bash-completion;
     description = "Programmable completion for the bash shell";
-    license = "GPL";
-
-    platforms = stdenv.lib.platforms.unix;
-    maintainers = [ stdenv.lib.maintainers.peti ];
+    license = licenses.gpl2Plus;
+    platforms = platforms.unix;
+    maintainers = [ maintainers.peti ];
   };
 }