about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2007-05-24 15:43:00 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2007-05-24 15:43:00 +0000
commit5021babc2074ee7f09e0bb052a1b052a3a0068d3 (patch)
tree4af387e95e8e79387b290ca3dc1f1ae29344ea94 /pkgs/shells
parent37aa92faec609a6d2b6869f56ae5cdf7272f2fd2 (diff)
downloadnixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.tar
nixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.tar.gz
nixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.tar.bz2
nixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.tar.lz
nixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.tar.xz
nixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.tar.zst
nixlib-5021babc2074ee7f09e0bb052a1b052a3a0068d3.zip
svn path=/nixpkgs/trunk/; revision=8760
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash/bash32-001.patch47
-rw-r--r--pkgs/shells/bash/default.nix27
-rw-r--r--pkgs/shells/bash/winsize.patch14
3 files changed, 0 insertions, 88 deletions
diff --git a/pkgs/shells/bash/bash32-001.patch b/pkgs/shells/bash/bash32-001.patch
deleted file mode 100644
index 9f8a885df1f2..000000000000
--- a/pkgs/shells/bash/bash32-001.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-			     BASH PATCH REPORT
-			     =================
-
-Bash-Release: 3.2
-Patch-ID: bash32-001
-
-Bug-Reported-by:	Greg Schafer <gschafer@zip.com.au>
-Bug-Reference-ID:	<20061012084940.GA15768@tigers.local>
-Bug-Reference-URL:	http://lists.gnu.org/archive/html/bug-bash/2006-10/msg00046.html
-
-Bug-Description:
-
-When using historical ``-style command substitution, bash incorrectly attempts
-to interpret shell comments while scanning for the closing backquote.
-
-Patch:
-
-*** bash-3.2/parse.y	Tue Sep 19 16:37:21 2006
---- new-bash/parse.y	Thu Oct 12 10:30:57 2006
-***************
-*** 2736,2740 ****
-    count = 1;
-    pass_next_character = backq_backslash = was_dollar = in_comment = 0;
-!   check_comment = (flags & P_COMMAND) && qc != '\'' && qc != '"' && (flags & P_DQUOTE) == 0;
-  
-    /* RFLAGS is the set of flags we want to pass to recursive calls. */
---- 2736,2740 ----
-    count = 1;
-    pass_next_character = backq_backslash = was_dollar = in_comment = 0;
-!   check_comment = (flags & P_COMMAND) && qc != '`' && qc != '\'' && qc != '"' && (flags & P_DQUOTE) == 0;
-  
-    /* RFLAGS is the set of flags we want to pass to recursive calls. */
-*** bash-3.2/patchlevel.h	Thu Apr 13 08:31:04 2006
---- new-bash/patchlevel.h	Mon Oct 16 14:22:54 2006
-***************
-*** 26,30 ****
-     looks for to find the patch level (for the sccs version string). */
-  
-! #define PATCHLEVEL 0
-  
-  #endif /* _PATCHLEVEL_H_ */
---- 26,30 ----
-     looks for to find the patch level (for the sccs version string). */
-  
-! #define PATCHLEVEL 1
-  
-  #endif /* _PATCHLEVEL_H_ */
diff --git a/pkgs/shells/bash/default.nix b/pkgs/shells/bash/default.nix
deleted file mode 100644
index be22f045cd91..000000000000
--- a/pkgs/shells/bash/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{stdenv, fetchurl, bison}:
-
-stdenv.mkDerivation {
-  name = "bash-3.2";
-
-  src = fetchurl {
-    url = http://ftp.gnu.org/pub/gnu/bash/bash-3.2.tar.gz;
-    md5 = "00bfa16d58e034e3c2aa27f390390d30";
-  };
-
-  postInstall = "ln -s bash $out/bin/sh";
-
-  patches = [
-    # Fix a nasty bug in bash-3.2.
-    ./bash32-001.patch
-  
-    # For dietlibc builds.
-    ./winsize.patch
-  ];
-
-  # !!! only needed for bash-3.2 (because of bash32-001.patch)
-  buildInputs = [bison]; 
-
-  meta = {
-    description = "GNU Bourne-Again Shell, the de facto standard shell on Linux";
-  };
-}
diff --git a/pkgs/shells/bash/winsize.patch b/pkgs/shells/bash/winsize.patch
deleted file mode 100644
index bbe4151e0cc7..000000000000
--- a/pkgs/shells/bash/winsize.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -rc bash-3.1-orig/lib/sh/winsize.c bash-3.1/lib/sh/winsize.c
-*** bash-3.1-orig/lib/sh/winsize.c	2006-10-18 18:08:25.000000000 +0200
---- bash-3.1/lib/sh/winsize.c	2006-10-18 18:10:00.000000000 +0200
-***************
-*** 30,35 ****
---- 30,37 ----
-  
-  #include <sys/ioctl.h>
-  
-+ #include <termios.h>
-+ 
-  #if !defined (STRUCT_WINSIZE_IN_SYS_IOCTL)
-  /* For struct winsize on SCO */
-  /*   sys/ptem.h has winsize but needs mblk_t from sys/stream.h */