about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-12-05 10:24:58 +0100
committerVladimír Čunát <vcunat@gmail.com>2015-12-05 10:26:06 +0100
commit476c96b5c61820a5034e5b9c526920b863f226ff (patch)
tree291f7cf487cddd1dc814664c1f7ded2ae9374d8c /pkgs/shells
parent3c437a643fff579909702229c1a8521600feba16 (diff)
parenteeb2935ac5a74eeb3d2e32f311fd6e6ef743e78c (diff)
downloadnixlib-476c96b5c61820a5034e5b9c526920b863f226ff.tar
nixlib-476c96b5c61820a5034e5b9c526920b863f226ff.tar.gz
nixlib-476c96b5c61820a5034e5b9c526920b863f226ff.tar.bz2
nixlib-476c96b5c61820a5034e5b9c526920b863f226ff.tar.lz
nixlib-476c96b5c61820a5034e5b9c526920b863f226ff.tar.xz
nixlib-476c96b5c61820a5034e5b9c526920b863f226ff.tar.zst
nixlib-476c96b5c61820a5034e5b9c526920b863f226ff.zip
Merge master into staging
Taken the version from recent channel bump, as it's well-tested.
Close #11460.
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/fish/default.nix2
-rw-r--r--pkgs/shells/nix-zsh-completions/default.nix25
-rw-r--r--pkgs/shells/pash/default.nix8
-rw-r--r--pkgs/shells/zsh/default.nix18
4 files changed, 43 insertions, 10 deletions
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 7ee4bd8707d1..c4386b1a9fb8 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -28,6 +28,8 @@ stdenv.mkDerivation rec {
     sed -e "s|gettext |${gettext}/bin/gettext |" \
         -e "s|which |${which}/bin/which |" \
         -i "$out/share/fish/functions/_.fish"
+    substituteInPlace "$out/share/fish/functions/fish_default_key_bindings.fish" \
+      --replace "clear;" "${ncurses}/bin/clear;"
   '' + stdenv.lib.optionalString (!stdenv.isDarwin) ''
     sed -i "s|Popen(\['manpath'|Popen(\['${man_db}/bin/manpath'|" "$out/share/fish/tools/create_manpage_completions.py"
   '' + ''
diff --git a/pkgs/shells/nix-zsh-completions/default.nix b/pkgs/shells/nix-zsh-completions/default.nix
new file mode 100644
index 000000000000..af7b4a746f4d
--- /dev/null
+++ b/pkgs/shells/nix-zsh-completions/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  name = "nix-zsh-completions";
+
+  src = fetchFromGitHub {
+    owner = "spwhitt";
+    repo = "nix-zsh-completions";
+    rev = "0.2";
+    sha256 = "0wimjdxnkw1lzhjn28zm4pgbij86ym0z17ayivpzz27g0sacimga";
+  };
+
+  installPhase = ''
+    mkdir -p $out/share/zsh/site-functions
+    cp _* $out/share/zsh/site-functions
+  '';
+
+  meta = {
+    homepage = "http://github.com/spwhitt/nix-zsh-completions";
+    description = "ZSH completions for Nix, NixOS, and NixOps";
+    license = stdenv.lib.licenses.bsd3;
+    platforms = stdenv.lib.platforms.all;
+    maintainers = [ stdenv.lib.maintainers.spwhitt ];
+  };
+}
diff --git a/pkgs/shells/pash/default.nix b/pkgs/shells/pash/default.nix
index 63669def0ab5..b9a8397e3ba1 100644
--- a/pkgs/shells/pash/default.nix
+++ b/pkgs/shells/pash/default.nix
@@ -15,11 +15,11 @@ buildDotnetPackage rec {
 
   outputFiles = [ "Source/PashConsole/bin/Release/*" ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "An open source implementation of Windows PowerShell";
     homepage = https://github.com/Pash-Project/Pash;
-    maintainers = stdenv.lib.maintainers.fornever;
-    platforms = with stdenv.lib.platforms; all;
-    license = with stdenv.lib.licenses; [ bsd3 gpl3 ];
+    maintainers = [ maintainers.fornever ];
+    platforms = platforms.all;
+    license = with licenses; [ bsd3 gpl3 ];
   };
 }
diff --git a/pkgs/shells/zsh/default.nix b/pkgs/shells/zsh/default.nix
index 0e25bba9fe35..7b12ab7cab81 100644
--- a/pkgs/shells/zsh/default.nix
+++ b/pkgs/shells/zsh/default.nix
@@ -21,13 +21,19 @@ stdenv.mkDerivation {
 
   buildInputs = [ ncurses coreutils pcre ];
 
-  preConfigure = ''
-    configureFlags="--enable-maildir-support --enable-multibyte --enable-zprofile=$out/etc/zprofile --with-tcsetpgrp --enable-pcre"
-  '';
+  configureFlags = [
+    "--enable-maildir-support"
+    "--enable-multibyte"
+    "--enable-zprofile=$out/etc/zprofile"
+    "--with-tcsetpgrp"
+    "--enable-pcre"
+  ];
 
-  # Some tests fail on hydra, see
-  # http://hydra.nixos.org/build/25637689/nixlog/1
-  doCheck = false;
+  # the zsh/zpty module is not available on hydra
+  # so skip groups Y Z
+  checkFlagsArray = ''
+    (TESTNUM=A TESTNUM=B TESTNUM=C TESTNUM=D TESTNUM=E TESTNUM=V TESTNUM=W)
+  '';
 
   # XXX: think/discuss about this, also with respect to nixos vs nix-on-X
   postInstall = ''