about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorGuillaume Girol <symphorien+git@xlumurb.eu>2023-01-21 12:00:00 +0000
committerGuillaume Girol <symphorien+git@xlumurb.eu>2023-01-21 12:00:00 +0000
commit33afbf39f6f2a6b37e99f070ba7d17a28c416d02 (patch)
tree6431c14751da2ff638abc06b1c8e11f99315f2c3 /pkgs/shells
parent25193e2732e178f701f517ca15ff802f03b29933 (diff)
downloadnixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.tar
nixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.tar.gz
nixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.tar.bz2
nixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.tar.lz
nixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.tar.xz
nixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.tar.zst
nixlib-33afbf39f6f2a6b37e99f070ba7d17a28c416d02.zip
treewide: switch to nativeCheckInputs
checkInputs used to be added to nativeBuildInputs. Now we have
nativeCheckInputs to do that instead. Doing this treewide change allows
to keep hashes identical to before the introduction of
nativeCheckInputs.
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash/5.nix2
-rw-r--r--pkgs/shells/bash/bash-completion/default.nix2
-rw-r--r--pkgs/shells/bash/blesh/default.nix2
-rw-r--r--pkgs/shells/fish/default.nix2
-rw-r--r--pkgs/shells/fish/plugins/bass.nix2
-rw-r--r--pkgs/shells/fish/plugins/build-fish-plugin.nix6
-rw-r--r--pkgs/shells/fish/plugins/fzf-fish.nix2
-rw-r--r--pkgs/shells/fish/plugins/pure.nix2
-rw-r--r--pkgs/shells/xonsh/default.nix2
9 files changed, 11 insertions, 11 deletions
diff --git a/pkgs/shells/bash/5.nix b/pkgs/shells/bash/5.nix
index 40db2abe03ab..7735243d3bab 100644
--- a/pkgs/shells/bash/5.nix
+++ b/pkgs/shells/bash/5.nix
@@ -92,7 +92,7 @@ stdenv.mkDerivation rec {
     "SHOBJ_LIBS=-lbash"
   ];
 
-  checkInputs = [ util-linux ];
+  nativeCheckInputs = [ util-linux ];
   doCheck = false; # dependency cycle, needs to be interactive
 
   postInstall = ''
diff --git a/pkgs/shells/bash/bash-completion/default.nix b/pkgs/shells/bash/bash-completion/default.nix
index d73afa7e2a97..48139babe1d4 100644
--- a/pkgs/shells/bash/bash-completion/default.nix
+++ b/pkgs/shells/bash/bash-completion/default.nix
@@ -26,7 +26,7 @@ stdenv.mkDerivation rec {
   # tests are super flaky unfortunately, and regularily break.
   # let's disable them for now.
   doCheck = false;
-  checkInputs = [
+  nativeCheckInputs = [
     # perl is assumed by perldoc completion
     perl
     # ps assumed to exist by gdb, killall, pgrep, pidof,
diff --git a/pkgs/shells/bash/blesh/default.nix b/pkgs/shells/bash/blesh/default.nix
index 26ff975dae33..8c1fc271645b 100644
--- a/pkgs/shells/bash/blesh/default.nix
+++ b/pkgs/shells/bash/blesh/default.nix
@@ -18,7 +18,7 @@ stdenvNoCC.mkDerivation rec {
   dontBuild = true;
 
   doCheck = true;
-  checkInputs = [ bashInteractive glibcLocales ];
+  nativeCheckInputs = [ bashInteractive glibcLocales ];
   preCheck = "export LC_ALL=en_US.UTF-8";
 
   installPhase = ''
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 7c9d90aa01a1..a24a38081afe 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -227,7 +227,7 @@ let
 
     doCheck = true;
 
-    checkInputs = [
+    nativeCheckInputs = [
       coreutils
       (python3.withPackages (ps: [ ps.pexpect ]))
       procps
diff --git a/pkgs/shells/fish/plugins/bass.nix b/pkgs/shells/fish/plugins/bass.nix
index db2907bddf40..35b36e29d544 100644
--- a/pkgs/shells/fish/plugins/bass.nix
+++ b/pkgs/shells/fish/plugins/bass.nix
@@ -16,7 +16,7 @@ buildFishPlugin rec {
     cp functions/__bass.py $out/share/fish/vendor_functions.d/
   '';
 
-  checkInputs = [ python3 ];
+  nativeCheckInputs = [ python3 ];
   checkPhase = ''
     make test
   '';
diff --git a/pkgs/shells/fish/plugins/build-fish-plugin.nix b/pkgs/shells/fish/plugins/build-fish-plugin.nix
index 5bb4ffa243fc..b5d813133c5b 100644
--- a/pkgs/shells/fish/plugins/build-fish-plugin.nix
+++ b/pkgs/shells/fish/plugins/build-fish-plugin.nix
@@ -12,7 +12,7 @@ attrs@{
   preInstall ? "",
   postInstall ? "",
 
-  checkInputs ? [],
+  nativeCheckInputs ? [],
   # plugin packages to add to the vendor paths of the test fish shell
   checkPlugins ? [],
   # vendor directories to add to the function path of the test fish shell
@@ -61,10 +61,10 @@ stdenv.mkDerivation (drvAttrs // {
 
   inherit doCheck;
 
-  checkInputs = [ (wrapFish {
+  nativeCheckInputs = [ (wrapFish {
     pluginPkgs = checkPlugins;
     functionDirs = checkFunctionDirs;
-  }) ] ++ checkInputs;
+  }) ] ++ nativeCheckInputs;
 
   checkPhase = ''
     export HOME=$(mktemp -d)  # fish wants a writable home
diff --git a/pkgs/shells/fish/plugins/fzf-fish.nix b/pkgs/shells/fish/plugins/fzf-fish.nix
index 5f55808cb514..2480b9ea93cb 100644
--- a/pkgs/shells/fish/plugins/fzf-fish.nix
+++ b/pkgs/shells/fish/plugins/fzf-fish.nix
@@ -11,7 +11,7 @@ buildFishPlugin rec {
     sha256 = "sha256-XmRGe39O3xXmTvfawwT2mCwLIyXOlQm7f40mH5tzz+s=";
   };
 
-  checkInputs = [ fzf fd util-linux ];
+  nativeCheckInputs = [ fzf fd util-linux ];
   checkPlugins = [ clownfish fishtape_3 ];
   checkFunctionDirs = [ "./functions" ];
   checkPhase = ''
diff --git a/pkgs/shells/fish/plugins/pure.nix b/pkgs/shells/fish/plugins/pure.nix
index 68da97633c4f..dae5cf783010 100644
--- a/pkgs/shells/fish/plugins/pure.nix
+++ b/pkgs/shells/fish/plugins/pure.nix
@@ -19,7 +19,7 @@ buildFishPlugin rec {
   # and https://github.com/pure-fish/pure/pull/275.
   doCheck = false;
 
-  checkInputs = [ git ];
+  nativeCheckInputs = [ git ];
   checkPlugins = [ fishtape ];
   checkPhase = ''
     # https://github.com/rafaelrinaldi/pure/issues/264
diff --git a/pkgs/shells/xonsh/default.nix b/pkgs/shells/xonsh/default.nix
index c8ab4bba9854..b25f88fec053 100644
--- a/pkgs/shells/xonsh/default.nix
+++ b/pkgs/shells/xonsh/default.nix
@@ -75,7 +75,7 @@ python3Packages.buildPythonApplication rec {
     HOME=$TMPDIR
   '';
 
-  checkInputs = [ glibcLocales git ] ++
+  nativeCheckInputs = [ glibcLocales git ] ++
     (with python3Packages; [ pyte pytestCheckHook pytest-mock pytest-subprocess ]);
 
   propagatedBuildInputs = with python3Packages; [ ply prompt-toolkit pygments ];