about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorNaïm Favier <n@monade.li>2023-01-12 16:10:24 +0100
committerGitHub <noreply@github.com>2023-01-12 16:10:24 +0100
commit16941b18c23d8bef3fb5681437301dfc32019168 (patch)
tree17af7eab9863c076b0c45121b8b996fba5c5443b /pkgs/shells
parent832bdf74072489b8da042f9769a0a2fac9b579c7 (diff)
parent288a8815e07ed5f804c9e9db581ecb5c90f97753 (diff)
downloadnixlib-16941b18c23d8bef3fb5681437301dfc32019168.tar
nixlib-16941b18c23d8bef3fb5681437301dfc32019168.tar.gz
nixlib-16941b18c23d8bef3fb5681437301dfc32019168.tar.bz2
nixlib-16941b18c23d8bef3fb5681437301dfc32019168.tar.lz
nixlib-16941b18c23d8bef3fb5681437301dfc32019168.tar.xz
nixlib-16941b18c23d8bef3fb5681437301dfc32019168.tar.zst
nixlib-16941b18c23d8bef3fb5681437301dfc32019168.zip
Merge pull request #208919 from joedevivo/zimfw
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/zimfw/default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/pkgs/shells/zsh/zimfw/default.nix b/pkgs/shells/zsh/zimfw/default.nix
new file mode 100644
index 000000000000..f78723ee6e2b
--- /dev/null
+++ b/pkgs/shells/zsh/zimfw/default.nix
@@ -0,0 +1,45 @@
+{ stdenv, lib, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  pname = "zimfw";
+  version = "1.11.0";
+  src = fetchFromGitHub {
+    owner = "zimfw";
+    repo = "zimfw";
+    rev = "v${version}";
+    ## zim only needs this one file to be installed.
+    sparseCheckout = [ "zimfw.zsh" ];
+    sha256 = "sha256-BmzYAgP5Z77VqcpAB49cQLNuvQX1qcKmAh9BuXsy2pA=";
+  };
+  strictDeps = true;
+  dontConfigure = true;
+  dontBuild = true;
+
+  installPhase = ''
+    runHook preInstall
+
+    mkdir -p $out
+    cp -r $src/zimfw.zsh $out/
+
+    runHook postInstall
+  '';
+
+  ## zim automates the downloading of any plugins you specify in the `.zimrc`
+  ## file. To do that with Nix, you'll need $ZIM_HOME to be writable.
+  ## `~/.cache/zim` is a good place for that. The problem is that zim also
+  ## looks for `zimfw.zsh` there, so we're going to tell it here to look for
+  ## the `zimfw.zsh` where we currently are.
+  postFixup = ''
+    substituteInPlace $out/zimfw.zsh \
+      --replace "\''${ZIM_HOME}/zimfw.zsh" "$out/zimfw.zsh"
+  '';
+
+  meta = with lib; {
+    description =
+      "The Zsh configuration framework with blazing speed and modular extensions";
+    homepage = "https://zimfw.sh";
+    license = licenses.mit;
+    maintainers = [ maintainers.joedevivo ];
+    platforms = platforms.all;
+  };
+}