about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorhappysalada <raphael@megzari.com>2023-10-28 07:29:09 +0100
committerYt <happysalada@tuta.io>2023-10-28 11:13:05 +0000
commit16920f9fe9bfe247a38c3f3c781683324c122e48 (patch)
treedd6b7613907ce355166795bbd75261bc197816b4 /pkgs/shells
parent1b3b4528d12fe65f692723e5179e96762fb62f9e (diff)
downloadnixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.tar
nixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.tar.gz
nixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.tar.bz2
nixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.tar.lz
nixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.tar.xz
nixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.tar.zst
nixlib-16920f9fe9bfe247a38c3f3c781683324c122e48.zip
nushellPlugins.regex: fix darwin build
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/nushell/plugins/default.nix2
-rw-r--r--pkgs/shells/nushell/plugins/regex.nix6
2 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/shells/nushell/plugins/default.nix b/pkgs/shells/nushell/plugins/default.nix
index bb3f631cf225..f4571d4da002 100644
--- a/pkgs/shells/nushell/plugins/default.nix
+++ b/pkgs/shells/nushell/plugins/default.nix
@@ -4,6 +4,6 @@ lib.makeScope newScope (self: with self; {
   gstat = callPackage ./gstat.nix { inherit Security; };
   formats = callPackage ./formats.nix { inherit IOKit Foundation; };
   query = callPackage ./query.nix { inherit IOKit CoreFoundation; };
-  regex = callPackage ./regex.nix { };
+  regex = callPackage ./regex.nix { inherit IOKit; };
   net = callPackage ./net.nix { inherit IOKit CoreFoundation; };
 })
diff --git a/pkgs/shells/nushell/plugins/regex.nix b/pkgs/shells/nushell/plugins/regex.nix
index 24cffddc27c2..4689a8390257 100644
--- a/pkgs/shells/nushell/plugins/regex.nix
+++ b/pkgs/shells/nushell/plugins/regex.nix
@@ -1,7 +1,9 @@
-{ lib
+{ stdenv
+, lib
 , rustPlatform
 , fetchFromGitHub
 , nix-update-script
+, IOKit
 }:
 
 rustPlatform.buildRustPackage {
@@ -17,6 +19,8 @@ rustPlatform.buildRustPackage {
 
   cargoHash = "sha256-AACpzSavY6MlYnl1lDYxVlfsEvEpNK0u8SzsoSZbqFc=";
 
+  buildInputs = lib.optionals stdenv.isDarwin [ IOKit ];
+
   passthru = {
     updateScript = nix-update-script { };
   };