about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-10-16 11:17:12 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2019-10-16 11:17:12 +0200
commit12441bdf9f09a4d355f927f9b2957a90d5c98822 (patch)
tree9a57120c6f99ed0e7abc62e5ced7db816df79a6b /pkgs/shells
parent41abe12bb38266e421e61a1332953a6a0409ea5f (diff)
parent22bbaf09fedc7ca9addc59c9b1738fc0b83fe2fd (diff)
downloadnixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.tar
nixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.tar.gz
nixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.tar.bz2
nixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.tar.lz
nixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.tar.xz
nixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.tar.zst
nixlib-12441bdf9f09a4d355f927f9b2957a90d5c98822.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/oh-my-zsh/default.nix6
-rw-r--r--pkgs/shells/zsh/zsh-history/0001-Fix-path-marshalling-when-saveing-config.patch25
-rw-r--r--pkgs/shells/zsh/zsh-history/default.nix36
3 files changed, 64 insertions, 3 deletions
diff --git a/pkgs/shells/zsh/oh-my-zsh/default.nix b/pkgs/shells/zsh/oh-my-zsh/default.nix
index 450ce6471255..3ad542e2a0a2 100644
--- a/pkgs/shells/zsh/oh-my-zsh/default.nix
+++ b/pkgs/shells/zsh/oh-my-zsh/default.nix
@@ -4,13 +4,13 @@
 { stdenv, fetchgit }:
 
 stdenv.mkDerivation rec {
-  version = "2019-10-09";
+  version = "2019-10-15";
   pname = "oh-my-zsh";
-  rev = "710a3d5a1e2888a4dfb1769f8f1edd8a590eee22";
+  rev = "f56b678888c0ad4ac71458680d75d88b442cf09b";
 
   src = fetchgit { inherit rev;
     url = "https://github.com/robbyrussell/oh-my-zsh";
-    sha256 = "0yckzrinlggyr40qc0cib3nw631vgy8nryiazyjw1mlx8iq1dskd";
+    sha256 = "0d8xbnq3icqyn88awc213jy0dmmb0ma0xqxayj7zyxwns9mrpd82";
   };
 
   pathsToLink = [ "/share/oh-my-zsh" ];
diff --git a/pkgs/shells/zsh/zsh-history/0001-Fix-path-marshalling-when-saveing-config.patch b/pkgs/shells/zsh/zsh-history/0001-Fix-path-marshalling-when-saveing-config.patch
new file mode 100644
index 000000000000..0c4fd22c54f5
--- /dev/null
+++ b/pkgs/shells/zsh/zsh-history/0001-Fix-path-marshalling-when-saveing-config.patch
@@ -0,0 +1,25 @@
+From efc16fbe7e41784f218d9c6cb4239b209cd77214 Mon Sep 17 00:00:00 2001
+From: Christian Kampka <christian@kampka.net>
+Date: Sat, 12 Oct 2019 21:47:47 +0200
+Subject: [PATCH 1/2] Fix path marshalling when saveing config
+
+---
+ config/config.go | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/config/config.go b/config/config.go
+index 69a10c5..b5c61fe 100644
+--- a/config/config.go
++++ b/config/config.go
+@@ -26,7 +26,7 @@ func (p *Path) UnmarshalText(text []byte) error {
+ 	return nil
+ }
+ 
+-func (p *Path) MarshalText() (text []byte, err error) {
++func (p Path) MarshalText() (text []byte, err error) {
+ 	return []byte(p.path), nil
+ }
+ 
+-- 
+2.19.2
+
diff --git a/pkgs/shells/zsh/zsh-history/default.nix b/pkgs/shells/zsh/zsh-history/default.nix
new file mode 100644
index 000000000000..6bbcdac2c171
--- /dev/null
+++ b/pkgs/shells/zsh/zsh-history/default.nix
@@ -0,0 +1,36 @@
+{ lib, fetchFromGitHub, buildGoModule, installShellFiles }:
+
+buildGoModule rec {
+  pname = "zsh-history";
+  version = "2019-10-07";
+
+  src = fetchFromGitHub {
+    owner = "b4b4r07";
+    repo = "history";
+    rev = "a08ad2dcffc852903ae54b0c5704b8a085009ef7";
+    sha256 = "0r3p04my40dagsq1dssnk583qrlcps9f7ajp43z7mq73q3hrya5s";
+  };
+
+  patches = [
+    ./0001-Fix-path-marshalling-when-saveing-config.patch
+  ];
+
+  nativeBuildInputs = [ installShellFiles ];
+
+  modSha256 = "0f10b86gyn7m7lw43c8y1m30mdg0i092a319v3cb2qj05jb9vn42";
+  goPackagePath = "github.com/b4b4r07/history";
+
+  postInstall = ''
+    install -d $out/share
+    cp -r "$NIX_BUILD_TOP/source/misc/"* "$out/share"
+    installShellCompletion --zsh --name _history $out/share/zsh/completions/_history
+  '';
+
+  meta = with lib; {
+    description = "A CLI to provide enhanced history for your ZSH shell";
+    license = licenses.mit;
+    homepage = https://github.com/b4b4r07/history;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ kampka ];
+  };
+}