about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorHoang Xuan Phu <phuhimself@phunehehe.net>2015-12-31 17:02:45 +0800
committerHoang Xuan Phu <phuhimself@phunehehe.net>2015-12-31 17:03:48 +0800
commitff49b7f91e487cf61851372e0d41f7681322072f (patch)
tree2e05a55dc78a748973f8ca98804fb7a1b2abc6f0 /pkgs/servers
parent3b065f0215615566c9ae4de91820892d191f9588 (diff)
downloadnixlib-ff49b7f91e487cf61851372e0d41f7681322072f.tar
nixlib-ff49b7f91e487cf61851372e0d41f7681322072f.tar.gz
nixlib-ff49b7f91e487cf61851372e0d41f7681322072f.tar.bz2
nixlib-ff49b7f91e487cf61851372e0d41f7681322072f.tar.lz
nixlib-ff49b7f91e487cf61851372e0d41f7681322072f.tar.xz
nixlib-ff49b7f91e487cf61851372e0d41f7681322072f.tar.zst
nixlib-ff49b7f91e487cf61851372e0d41f7681322072f.zip
postfix: patch to stop hard coding SHELL
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/postfix/2.11.nix5
-rw-r--r--pkgs/servers/mail/postfix/3.0.nix2
-rw-r--r--pkgs/servers/mail/postfix/default.nix7
-rw-r--r--pkgs/servers/mail/postfix/postfix-script-shell.patch21
4 files changed, 33 insertions, 2 deletions
diff --git a/pkgs/servers/mail/postfix/2.11.nix b/pkgs/servers/mail/postfix/2.11.nix
index bfd10fb591b2..7c936bf12446 100644
--- a/pkgs/servers/mail/postfix/2.11.nix
+++ b/pkgs/servers/mail/postfix/2.11.nix
@@ -13,7 +13,10 @@ stdenv.mkDerivation rec {
     sha256 = "11riz8ggaa09pi8d6xv2807qp7yjn918mrylfvkfwmvcdlgwck0a";
   };
 
-  patches = [ ./postfix-2.11.0.patch ];
+  patches = [
+    ./postfix-2.11.0.patch
+    ./postfix-script-shell.patch
+  ];
 
   buildInputs = [ makeWrapper gnused db openssl cyrus_sasl ];
 
diff --git a/pkgs/servers/mail/postfix/3.0.nix b/pkgs/servers/mail/postfix/3.0.nix
index 93f419bc7f68..8c625da2c9e2 100644
--- a/pkgs/servers/mail/postfix/3.0.nix
+++ b/pkgs/servers/mail/postfix/3.0.nix
@@ -15,6 +15,8 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ makeWrapper gnused db openssl cyrus_sasl icu ];
 
+  patches = [ ./postfix-script-shell.patch ];
+
   preBuild = ''
     sed -e '/^PATH=/d' -i postfix-install
 
diff --git a/pkgs/servers/mail/postfix/default.nix b/pkgs/servers/mail/postfix/default.nix
index 7bd2d6209108..838ca7a8d8df 100644
--- a/pkgs/servers/mail/postfix/default.nix
+++ b/pkgs/servers/mail/postfix/default.nix
@@ -14,7 +14,12 @@ stdenv.mkDerivation rec {
 
   buildInputs = [db openssl cyrus_sasl bison perl];
 
-  patches = [ ./postfix-2.2.9-db.patch  ./postfix-2.2.9-lib.patch ./db-linux3.patch ];
+  patches = [
+    ./postfix-2.2.9-db.patch
+    ./postfix-2.2.9-lib.patch
+    ./db-linux3.patch
+    ./postfix-script-shell.patch
+  ];
 
   postPatch = ''
     sed -i -e s,/usr/bin,/var/run/current-system/sw/bin, \
diff --git a/pkgs/servers/mail/postfix/postfix-script-shell.patch b/pkgs/servers/mail/postfix/postfix-script-shell.patch
new file mode 100644
index 000000000000..4f5d2f611110
--- /dev/null
+++ b/pkgs/servers/mail/postfix/postfix-script-shell.patch
@@ -0,0 +1,21 @@
+diff --git a/conf/postfix-script b/conf/postfix-script
+index 19088a6..04fae23 100755
+--- a/conf/postfix-script
++++ b/conf/postfix-script
+@@ -43,7 +43,6 @@ FATAL="$LOGGER -p fatal"
+ PANIC="$LOGGER -p panic"
+ 
+ umask 022
+-SHELL=/bin/sh
+ 
+ #
+ # Can't do much without these in place.
+@@ -229,7 +228,7 @@ status)
+ check-fatal)
+ 	# This command is NOT part of the public interface.
+ 
+-	$SHELL $daemon_directory/post-install create-missing || {
++	$daemon_directory/post-install create-missing || {
+ 		$FATAL unable to create missing queue directories
+ 		exit 1
+ 	}