about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-09-08 20:48:14 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-08 20:48:14 +0200
commitfebd5e323d08db5912e33d247a5f12275277dfb6 (patch)
treef50a941c9a2b6b52983d12ea371ad2118b058e42 /pkgs/servers
parent0061fae2e6fd62f6d2a76418b62815bd49add51c (diff)
parente9183fd2d4d3bb222b2ce3492935ec26d207524a (diff)
downloadnixlib-febd5e323d08db5912e33d247a5f12275277dfb6.tar
nixlib-febd5e323d08db5912e33d247a5f12275277dfb6.tar.gz
nixlib-febd5e323d08db5912e33d247a5f12275277dfb6.tar.bz2
nixlib-febd5e323d08db5912e33d247a5f12275277dfb6.tar.lz
nixlib-febd5e323d08db5912e33d247a5f12275277dfb6.tar.xz
nixlib-febd5e323d08db5912e33d247a5f12275277dfb6.tar.zst
nixlib-febd5e323d08db5912e33d247a5f12275277dfb6.zip
Merge remote-tracking branch 'upstream/master' into HEAD
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/atlassian/crowd.nix4
-rw-r--r--pkgs/servers/dict/default.nix19
-rw-r--r--pkgs/servers/mfi/default.nix28
-rw-r--r--pkgs/servers/nosql/mongodb/2.4.8.nix45
-rw-r--r--pkgs/servers/web-apps/searx/default.nix5
5 files changed, 20 insertions, 81 deletions
diff --git a/pkgs/servers/atlassian/crowd.nix b/pkgs/servers/atlassian/crowd.nix
index 0d78f361525b..6d7b332da135 100644
--- a/pkgs/servers/atlassian/crowd.nix
+++ b/pkgs/servers/atlassian/crowd.nix
@@ -3,11 +3,11 @@
 
 stdenv.mkDerivation rec {
   name = "atlassian-crowd-${version}";
-  version = "2.12.0";
+  version = "3.0.1";
 
   src = fetchurl {
     url = "https://www.atlassian.com/software/crowd/downloads/binary/${name}.tar.gz";
-    sha256 = "1kfnsa25axlyhnapfza381p94pyfixh7j999qhpg3ii821n9sggm";
+    sha256 = "17pz0rgzdv40sbvzb9w6xmdg598m6gs7gsznfnxcy1j011cgg1wr";
   };
 
   phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
diff --git a/pkgs/servers/dict/default.nix b/pkgs/servers/dict/default.nix
index ee0477734c2f..0e6c39ec9245 100644
--- a/pkgs/servers/dict/default.nix
+++ b/pkgs/servers/dict/default.nix
@@ -1,22 +1,31 @@
 { stdenv, fetchurl, which, bison, flex, libmaa, zlib, libtool }:
 
 stdenv.mkDerivation rec {
-  version = "1.12.1";
   name = "dictd-${version}";
+  version = "1.12.1";
 
   src = fetchurl {
     url = "mirror://sourceforge/dict/dictd-${version}.tar.gz";
     sha256 = "0min6v60b6z5mrymyjfwzx8nv6rdm8pd8phlwl6v2jl5vkngcdx2";
   };
 
-  buildInputs = [ flex bison which libmaa zlib libtool ];
+  buildInputs = [ libmaa zlib ];
+
+  nativeBuildInputs = [ bison flex libtool which ];
+
+  enableParallelBuilding = true;
 
   patchPhase = "patch -p0 < ${./buildfix.diff}";
-  configureFlags = "--datadir=/var/run/current-system/share/dictd";
+  configureFlags = [
+    "--enable-dictorg"
+    "--datadir=/run/current-system/share/dictd"
+  ];
 
   meta = with stdenv.lib; {
     description = "Dict protocol server and client";
-    maintainers = [ maintainers.mornfall ];
-    platforms = platforms.linux;
+    homepage    = http://www.dict.org;
+    license     = licenses.gpl2;
+    maintainers = with maintainers; [ mornfall ];
+    platforms   = platforms.linux;
   };
 }
diff --git a/pkgs/servers/mfi/default.nix b/pkgs/servers/mfi/default.nix
deleted file mode 100644
index e431ca993a90..000000000000
--- a/pkgs/servers/mfi/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ stdenv, fetchurl, unzip }:
-
-stdenv.mkDerivation rec {
-  name = "mfi-controller-${version}";
-  version = "2.1.11";
-
-  src = fetchurl {
-    url = "https://dl.ubnt.com/mfi/${version}/mFi.unix.zip";
-    sha256 = "0b9q6025zf9zjzq8dcmcyai8rslx67g52j41gacxsk9i5dspmw90";
-  };
-
-  buildInputs = [ unzip ];
-
-  dontBuild = true;
-
-  installPhase = ''
-    mkdir -p $out
-    cp -ar conf data dl lib webapps $out
-  '';
-
-  meta = with stdenv.lib; {
-    homepage = http://www.ubnt.com/;
-    description = "Controller for Ubiquiti mFi devices";
-    license = licenses.unfree;
-    platforms = platforms.unix;
-    maintainers = with maintainers; [ elitak ];
-  };
-}
diff --git a/pkgs/servers/nosql/mongodb/2.4.8.nix b/pkgs/servers/nosql/mongodb/2.4.8.nix
deleted file mode 100644
index ccd64da3c6a8..000000000000
--- a/pkgs/servers/nosql/mongodb/2.4.8.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-# This derivation was resurrected from 4c8ec5e12e187347fd97b1a1a9a43eb19e009ed0
-# by elitak for use with the Ubiquiti mFi Controller package, which breaks at
-# runtime on mongodb3+ and jre8+. We will need to pull in sufficiently old
-# versions of boost and v8 to build this, as well.
-{ stdenv, fetchurl, scons, boost155, v8_3_14, gperftools, pcre-cpp, snappy }:
-with stdenv.lib;
-let
-  version = "2.4.8";
-in
-stdenv.mkDerivation rec {
-  name = "mongodb-${version}";
-
-  src = fetchurl {
-    url = "http://downloads.mongodb.org/src/mongodb-src-r${version}.tar.gz";
-    sha256 = "1p6gnharypglfp39halp72fig96fqjhakyy7m76a1prxwpjkqw7x";
-  };
-
-  nativeBuildInputs = [ scons boost155 v8_3_14 gperftools pcre-cpp snappy ];
-
-  postPatch = ''
-    substituteInPlace SConstruct \
-        --replace "Environment( BUILD_DIR" "Environment( ENV = os.environ, BUILD_DIR" \
-        --replace 'CCFLAGS=["-Werror", "-pipe"]' 'CCFLAGS=["-pipe"]'
-  '';
-
-  NIX_CFLAGS_COMPILE = "-Wno-unused-local-typedefs";
-
-  buildPhase = ''
-    export SCONSFLAGS="-j$NIX_BUILD_CORES"
-    scons all --use-system-all
-  '';
-
-  installPhase = ''
-    mkdir -p $out/lib
-    scons install --use-system-all --full --prefix=$out
-  '';
-
-  meta = {
-    description = "A scalable, high-performance, open source NoSQL database";
-    homepage = http://www.mongodb.org;
-    license = licenses.agpl3;
-    maintainers = with maintainers; [ bluescreen303 elitak ];
-    platforms = platforms.linux;
-  };
-}
diff --git a/pkgs/servers/web-apps/searx/default.nix b/pkgs/servers/web-apps/searx/default.nix
index 0feae7d72411..1c5f52d4938e 100644
--- a/pkgs/servers/web-apps/searx/default.nix
+++ b/pkgs/servers/web-apps/searx/default.nix
@@ -17,7 +17,10 @@ pythonPackages.buildPythonApplication rec {
       --replace 'certifi==2017.1.23' 'certifi' \
       --replace 'lxml==3.7.3' 'lxml' \
       --replace 'pyopenssl==16.2.0' 'pyopenssl' \
-      --replace 'pygments==2.1.3' 'pygments>=2.1,<3.0'
+      --replace 'pygments==2.1.3' 'pygments>=2.1,<3.0' \
+      --replace 'flask==0.12' 'flask==0.12.*' \
+      --replace 'requests[socks]==2.13.0' 'requests[socks]==2.*' \
+      --replace 'python-dateutil==2.6.0' 'python-dateutil==2.6.*'
   '';
 
   propagatedBuildInputs = with pythonPackages; [